Closed Bug 1459007 Opened 2 years ago Closed 2 years ago

Sidebar automatically opens UBLOCK (extension) log whenever brower is started.

Categories

(WebExtensions :: Frontend, defect)

59 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: cmonster67, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180427210249

Steps to reproduce:

Open firefox.


Actual results:

The extension uBlock's log is automatically opened whenever firefox is started.


Expected results:

Nothing should open in the sidebar. The uBlock developer told me that automatically opening the sidebar is NOT a function in the extension.  It happens even when firefox is closed gracefully.  No other extensions have the issue and this did not happen with previous versions of firefox.
Note that I currently cannot reproduce this behavior. But I do see once in a while the sidebar opening with uBlock Origin's logger (very rare, and mostly I think when I drop a new version of the extension during development). I usually just close it and this does not re-occur. Currently trying to find repro steps but unable to get the issue.
@cmonster67: can you reproduce the issue in a brand new profile and just uBlock Origin?
I've upgraded to v60 (x64) and it still happens, the sidebar opens containing the ublock logger when I start firefox.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180427210249

Hi cmonster67,

I didn’t manage to reproduce the issue using a new profile with only uBlock Origin installed on  Firefox Release 59.0.3,  latest Nightly 62.0a1 and Firefox Beta 60.0 (Windows 10 x64). Restarted the browser several times without any success in reproducing.
Can you please retest the issue using a new clean Firefox profile (https://goo.gl/AWo6h8) with only uBlock Origin installed to eliminate custom settings as a possible cause? If so, please mention on which Firefox version did you attempt to reproduce the issue.
Also, could it be related to a specific site (for example: restarting the browser after visiting amazon.com) or is it totally random?

Thank you.
Flags: needinfo?(cmonster67)
Hi,

I'll try it with a clean profile and with only only uBlock installed and will get back to you.  FYI, the panel opens regardless of the site I had visited, it just happened every time I open firefox.

I'll do some more testing and will be in touch.

Thanks
Flags: needinfo?(cmonster67)
I can confirm that with Firefox 60 ESR, using group policy "extensions to install" for *only* uBlock Origin (using URL> https://addons.mozilla.org/firefox/downloads/file/935956/ublock_origin-1.16.2-an+fx.xpi?src=dp-btn-primary), a fresh Windows and Firefox profile opens the sidebar on first run with the uBlock Logger. Subsequent restarts of Firefox show the sidebar.  The sidebar only goes away once closed, and does not reappear for me on new FF restarts.

The issue I have is end-user confusion that will occur when we roll out 60 with the extension...I would be good with even a workaround that maybe disables the sidebar or forces it closed on FF start.
If it can't be fixed by Firefox in the short term, the only possible workaround for me is to remove the sidebarAction  from the manifest until this is fixed -- i.e. removing sidebar support in uBO.

Closing/opening the sidebar programmatically in uBO at start up does not work because this can be done only from within one of the following user interaction:

> You can only call this function from inside the handler
> for a user action, such as:
> 
> Clicking the extension's browser action or page action.
> Selecting a context menu item defined by the extension.
> Clicking a button in a page bundled with the extension.

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/sidebarAction/close
Assigned to a component in order to involve the development team in a proper review.
Component: Untriaged → WebExtensions: Frontend
Product: Firefox → Toolkit
based on comment 6 "The sidebar only goes away once closed, and does not reappear for me on new FF restarts." that is expected behavior.  sidebars all persist across restarts.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
@grep65535: I removed sidebar support for stable releases of uBO, so this should no longer occur in 1.16.6:

https://github.com/gorhill/uBlock/commit/4d8ccfdc05ecd499defc13d5ebf2423f8733d516
Mike, given comment 6 mentions group policy, you might want to scan this bug.
Flags: needinfo?(mozilla)
I verified that even if you just open Firefox and type:

https://addons.mozilla.org/firefox/downloads/file/935956/ublock_origin-1.16.2-an+fx.xpi?src=dp-btn-primary

in the URL bar, after install the Sidebar is opened.

So this is either a WebExtensions behavior or something that ublock was doing.

Policy is not involved.
Flags: needinfo?(mozilla)
uBlock is not causing it to happen. Sidebars are opened on install of an extension, so the behavior outlined is correct.  However, in this case it might be an unexpected effect when using the group policy to install. That's what I'm wondering about.  For that case is this UX wrong and should it change?
Flags: needinfo?(mozilla)
See Also: → 1460910
We currently just use a standard addon install:

https://searchfox.org/mozilla-central/source/browser/components/enterprisepolicies/Policies.jsm#446

There's nothing that identifies the addon as installed by group policy. So this would probably be non trivial.

I've opened bug 1460910 for this.
Flags: needinfo?(mozilla)
Upgraded to v60.0.1 (x64) and no automatic opening of sidebar!  Will continue testing for the next couple of days to make sure that the issue is resolved.
Given comment #15 mentioning 60.0.1's potential new behavior:
I imaged a new system and fed v60.0.1 (x64) to our process and the behavior is the same. Does 60.0.1 include the patch mentioned in bug 1460910 comment 5?
I will follow up with rhill@raymondhill.net's comment#10 and see if uBO 1.16.6 does it for us in the short term at least.
(In reply to rhill@raymondhill.net from comment #10)
> @grep65535: I removed sidebar support for stable releases of uBO, so this
> should no longer occur in 1.16.6:
> 
> https://github.com/gorhill/uBlock/commit/
> 4d8ccfdc05ecd499defc13d5ebf2423f8733d516

I modified the URL I'm using in GPO to reflect the version change and after testing I can confirm this works. Thank you for doing this, it saves a lot of us a lot of time. I will keep an eye on how the bug 1460910 thread goes as well.
> Does 60.0.1 include the patch mentioned in bug 1460910 comment 5?

It will be some time before this patch is created and checked in.
60.0.1 is still working on multiple computers.  Also upgraded to beta7 without any issues.
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.