Overflow menu WebExtension subview header text is invisible on dark theme

RESOLVED FIXED in Firefox 61

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: ntim, Assigned: jaws)

Tracking

(Blocks 1 bug, {regression})

unspecified
mozilla62
Dependency tree / graph
Bug Flags:
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61+ fixed, firefox62+ fixed)

Details

Attachments

(2 attachments)

Posted image Screenshot
The subview header containing the "<" arrow + the extension title is invisible on dark themes.

I think this is a regression of bug 1449933.
Flags: needinfo?(jaws)
Keywords: regression
Blocks: 1459046
See Also: → 1459047
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Comment on attachment 8973740 [details]
Bug 1459066 - Overflow menu WebExtension subview header should use the default browser styling instead of the extension's styling.

https://reviewboard.mozilla.org/r/242120/#review248036

::: browser/components/extensions/ExtensionPopups.jsm:363
(Diff revision 3)
> +    if (this.panel.id == "widget-overflow") {
> +      this.browser.style.background = background;
> +    } else {
> -    this.panel.style.setProperty("--arrowpanel-background", background);
> +      this.panel.style.setProperty("--arrowpanel-background", background);
> +    }

Is there any reason we shouldn't just always set the style on browser?
Comment on attachment 8973740 [details]
Bug 1459066 - Overflow menu WebExtension subview header should use the default browser styling instead of the extension's styling.

https://reviewboard.mozilla.org/r/242120/#review248036

> Is there any reason we shouldn't just always set the style on browser?

Because standalone popups should have the styles extend to the popup arrow. If we set the style on the browser all the time, we would still need to apply it to the arrow when it is standalone otherwise in most cases users would see a slight variation in the color of the arrow and top part of the popup box (rgb(252, 252, 252, 0.976) on OSX for example) and the browser (rgb(255, 255, 255)).
Attachment #8973740 - Flags: review?(mixedpuppy)
Comment on attachment 8973740 [details]
Bug 1459066 - Overflow menu WebExtension subview header should use the default browser styling instead of the extension's styling.

https://reviewboard.mozilla.org/r/242120/#review248678
Attachment #8973740 - Flags: review?(mixedpuppy) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1f3cab27183f
Overflow menu WebExtension subview header should use the default browser styling instead of the extension's styling. r=mixedpuppy
https://hg.mozilla.org/mozilla-central/rev/1f3cab27183f
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Please request Beta approval on this when you get a chance.
Flags: needinfo?(jaws)
Flags: in-testsuite+
Flags: qe-verify+
Comment on attachment 8973740 [details]
Bug 1459066 - Overflow menu WebExtension subview header should use the default browser styling instead of the extension's styling.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1449933
[User impact if declined]: when extensions that provide their own popup are placed in the overflow menu, the header for the popup can be unreadable on dark themes
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: limited to a special case of extension popups
[String changes made/needed]: none
Flags: needinfo?(jaws)
Attachment #8973740 - Flags: approval-mozilla-beta?
Flags: qe-verify+ → qe-verify-
Comment on attachment 8973740 [details]
Bug 1459066 - Overflow menu WebExtension subview header should use the default browser styling instead of the extension's styling.

Avoid unreadable text from extension popups with the dark theme enabled under some circumstances. Approved for 61.0b5.
Attachment #8973740 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.