Closed Bug 1459156 Opened 2 years ago Closed 2 months ago

Adding additional Django users via admin panel does not work

Categories

(Webtools :: Pontoon, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: exile, Assigned: mathjazz)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180406121424

Steps to reproduce:

When enabling Pontoon to work with Django users by enabling DJANGO_LOGIN=True, I tried to create a new user for testing via the Django admin /a panel.


Actual results:

Trying to add a new user fails with the following error:

ValueError at /a/auth/user/add/
"<User: test>" needs to have a value for field "id" before this many-to-many relationship can be used.

The only workaround for local user management at the moment seems to be creating additional superusers and removing the admin rights from these users via the Django admin panel /a


Expected results:

I would expect that even for testing/dev purposes it would be possible to add users via the Django /a interface.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Attached file stacktrace
I ran into the the same bug.
Here is the stacktrace:
Assignee: nobody → m
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.