Closed Bug 1459187 Opened 3 years ago Closed 2 years ago

laggy scroll on heavy css page (purecss-francine)

Categories

(Core :: Graphics: WebRender, defect, P3)

x86_64
All
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- disabled
firefox59 --- disabled
firefox60 --- disabled
firefox61 --- disabled

People

(Reporter: alice0775, Assigned: gw)

References

(Blocks 1 open bug, )

Details

(Keywords: perf)

Attachments

(1 file, 1 obsolete file)

Attached file about:support
Steps To Reproduce:
0. Reduce browser height 800-900px
1. Open https://cyanharlow.github.io/purecss-francine/
2. Wait for render the page
3. Try scroll up and down with mouse wheel or scroll thumb

Actual Results:
It is laggy when WebRender is enabled
Attachment #8973195 - Attachment is obsolete: true
This is slow even with the patches from bug 1457466, because rendering is slow.

https://perfht.ml/2JVzsLR
Duplicate of this bug: 1462384
See Also: → 1474294
This is a pretty malicious test case. I don't think we need to block nightly on it.
Blocks: stage-wr-trains
No longer blocks: stage-wr-nightly
Summary: laggy scroll on heavy css page → laggy scroll on heavy css page (purecss-francine)
Depends on: 1480317
Priority: P2 → P3
We need to decide how good we need to be at this for release. Let's talk about this next Wednesday.
Assignee: nobody → gwatson

This now scrolls very smoothly on my machine, with picture caching enabled by default.

It still takes a long time for the initial render, and we do invalidate / re-render on any changes to the scene geometry (e.g. resizing the window, opening devtools). It'd be nice to improve these in the future, but the general scrolling performance is good now, which covers the requirements for this bug.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.