Closed Bug 1459211 Opened 3 years ago Closed 1 year ago

Search bar doesn’t keep the search input if resizing the browser

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1389080
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- fix-optional

People

(Reporter: Anca, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]: 
- 61.0b2 dev edition
- 61.0a1 (2018-05-04)
- 60.0.

[Affected platforms]:
- macOS 10.13
- Windows 10 x64
- Ubuntu 16.04 x64

[Steps to reproduce]:
1. Launch Firefox
2. Enable the search bar from about:preferences#search by clicking on "Add search bar in toolbar" option.
3. Type something inside the Search bar.
4. Resize the browser until the Search bar disappears. 
5. Resize the browser back to the original form.  

[Expected result]:
- The previously inputted content is still displayed inside the Search bar.

[Actual result]:
- The previously inputted content disappears from the Search bar.

[Regression range]:
- I will try to find one asp.

[Additional notes]:
- Note that this behaviour is not reproducible if the Search bar is displayed on the Tab bar.
Possibly related to the overflow menu -- like the search bar reinits itself when it's moved to the overflow menu and/or when it moves back to the navbar.
Priority: -- → P3
This is an old regression

 Last good revision: a475f94bb1b1 (2013-11-17)
 First bad revision: f2adb62d07eb (2013-11-18)
 Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a475f94bb1b1&tochange=f2adb62d07eb
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389080
You need to log in before you can comment on or make changes to this bug.