feed daemon skips setting r+ for accepted revision if the same user already has a flag set even if flag is status of ?

RESOLVED FIXED

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: dkl, Assigned: dkl)

Tracking

({conduit-triaged})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

45 bytes, text/x-github-pull-request
Details | Review
The feed daemon loops over current flags and if the setter of the current flag is the same as the new flag being set, it skips adding that flag. Even if the current flags status is '?'. Originally it was designed this way thinking that only Phabricator would be setting review flags for those phabricator revision related patches (those that redirect to phabricator revisions). 

The change will only skip if the review flag is set to '+'. Otherwise it will add another review+ flag separately.

This may have the side effect of having more than one review flag set for an attachment. One with the status '?' set manually by a user, and one with status '+' set by phab-bot.

dkl
Posted file github pr #568
Duplicate of this bug: 1459329
Blocks: 1453733
Keywords: conduit-triaged
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.