Closed Bug 1459362 Opened Last year Closed Last year

Disable WebVR for macOS in Release for FF60

Categories

(Core :: WebVR, defect, major)

60 Branch
x86_64
macOS
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
relnote-firefox --- 60+
firefox-esr60 --- verified
firefox60 --- verified
firefox61 --- verified

People

(Reporter: kip, Assigned: kip)

References

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

We intended to shop WebVR support for macOS to release in FF60 (Bug 1438044); unfortunately, it has been regressed by Bug 1424709.

The OpenVR client fails with the nano allocator disabled, causing a failure to present to the VR headset and a loss of responsiveness when visiting WebVR sites with an HTC Vive attached.

To avoid negative impact to users on macOS with SteamVR installed, we will need to delay the macOS release of WebVR until a solution can be found.

I will append a patch to disable WebVR in release for macOS (Windows is not affected, and will continue to be supported in release)
Target Milestone: --- → mozilla60
Attachment #8973364 - Flags: review?(bugs)
Once confirmed that the try run passes, we will want to uplift this to beta and FF60 / release.
Comment on attachment 8973364 [details]
Bug 1459362 - Disable WebVR in release on macOS (Backed out changeset 1b24d52edebb)

https://reviewboard.mozilla.org/r/241824/#review247716
Attachment #8973364 - Flags: review?(bugs) → review+
Comment on attachment 8973364 [details]
Bug 1459362 - Disable WebVR in release on macOS (Backed out changeset 1b24d52edebb)

https://reviewboard.mozilla.org/r/241824/#review247716

Thanks, I will watch the try run just in case, then land in m-c and request uplift to beta and release.
Comment on attachment 8973364 [details]
Bug 1459362 - Disable WebVR in release on macOS (Backed out changeset 1b24d52edebb)

Approval Request Comment
[Feature/Bug causing the regression]:
Bug 1424709 ([macos] crash when changing macos network location) has regressed WebVR on macOS.  Windows support for WebVR is unaffected.
[User impact if declined]:
Users on macOS with an HTC Vive connected will see "Enter VR" options on WebVR sites, even though they will not be able to present to their headset.  Additionally, the browser will become less responsive while visiting those sites for users with SteamVR installed on macOS.
[Is this code covered by automated tests?]:
Yes
[Has the fix been verified in Nightly?]:
Currently landing in Nightly, running through try server to ensure doesn't break tests.
[Needs manual test from QE? If yes, steps to reproduce]: 
No, has not yet shipped to release.  Delaying the release shipping.  Could verify that macOS machines with SteamVR can visit sketchfab.com without seeing any "Enter VR" buttons.
[List of other uplifts needed for the feature/fix]:
N/A
[Is the change risky?]:
Low risk.
[Why is the change risky/not risky?]:
Changes affect only tests and one pref.  This patch ensures that FF60 release continues to have the same pref values as FF59 release.
[String changes made/needed]:
N/A
Attachment #8973364 - Flags: approval-mozilla-release?
Attachment #8973364 - Flags: approval-mozilla-beta?
Pushed by kgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/41d06ef57fe6
Disable WebVR in release on macOS (Backed out changeset 1b24d52edebb) r=smaug
https://hg.mozilla.org/mozilla-central/rev/41d06ef57fe6
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: mozilla60 → mozilla61
Comment on attachment 8973364 [details]
Bug 1459362 - Disable WebVR in release on macOS (Backed out changeset 1b24d52edebb)

Fx61 is already on Beta. That said, I suspect we'll want this landed on ESR60 eventually too.
Attachment #8973364 - Flags: approval-mozilla-beta? → approval-mozilla-esr60?
I can confirm this feature is disabled on Fx 61, I tested using Fx 61.0b3, on mac os 10.13.5 beta. I verified both the pref code (dom.vr.enabled->false) and the steps in comment 5.
However the feature is active on Fx60.0esr-build6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 8973364 [details]
Bug 1459362 - Disable WebVR in release on macOS (Backed out changeset 1b24d52edebb)

disable webvr on mac for 60.0.1 (+ corresponding esr)
Attachment #8973364 - Flags: approval-mozilla-release?
Attachment #8973364 - Flags: approval-mozilla-release+
Attachment #8973364 - Flags: approval-mozilla-esr60?
Attachment #8973364 - Flags: approval-mozilla-esr60+
Added this to Firefox and ESR 60.0.1 release notes.
I can confirm this feature is disabled on Fx 60.0.1-build2 and Fx 60.0.1esr-build1, I tested on mac OS 10.13.2.
needs documentation
Flags: needinfo?(cmills)
Keywords: dev-doc-needed
(In reply to j.j. from comment #15)
> needs documentation

You've added dev-doc-needed to the bug, so this will be picked up by our tools and we'll do this in the next run of doc fixes.

Thanks!
Updated https://developer.mozilla.org/en-US/Firefox/Releases/61 to mention this has been re-enabled for Firefox 61 for developers.

Also updated BCD for all the WebVR APIs.
Flags: needinfo?(cmills)
There's been some discussion about exactly what the state of WebVR on macOS is at the moment. We currently document it as shipping in 61, but there's some information that's been found suggesting that's not correct. Is WebVR on Mac enabled by default in 61? Or is it a later release?
Flags: needinfo?(kgilbert)
(In reply to Eric Shepherd [:sheppy] from comment #18)
> There's been some discussion about exactly what the state of WebVR on macOS
> is at the moment. We currently document it as shipping in 61, but there's
> some information that's been found suggesting that's not correct. Is WebVR
> on Mac enabled by default in 61? Or is it a later release?

WebVR was regressed due to an unrelated crash fix that required disabling the "Nano Allocator" on macOS.  With the Nano Allocator disabled, the OpenVR libraries required for macOS support for WebVR fail to start correctly.

The "Nano Allocator" is enabled on a per-process basis, so we could re-enable it just for the "VR Process", which will be implemented in Bug 1362578.  This work is already underway, and is expected in the FF62 - FF63 timeline.  The kind folks at Valve are also investigating from their end to see why their libraries are failing without the Nano Allocator.

tl;dr - This is not enabled by default in FF61.  It is expected to be re-enabled in FF62 or FF63.
Flags: needinfo?(kgilbert)
> tl;dr - This is not enabled by default in FF61.  It is expected to be re-enabled in FF62 or FF63.

Thank you! That's good to confirm. Is there a bug that I should watch that will definitively be resolved when the preference's default is switched to true? I presume that while bug 1362578 is a blocker for doing that, it is not necessarily the bug to watch to detect the default being switched on.
Flags: needinfo?(kgilbert)
(In reply to Eric Shepherd [:sheppy] from comment #20)
> > tl;dr - This is not enabled by default in FF61.  It is expected to be re-enabled in FF62 or FF63.
> 
> Thank you! That's good to confirm. Is there a bug that I should watch that
> will definitively be resolved when the preference's default is switched to
> true? I presume that while bug 1362578 is a blocker for doing that, it is
> not necessarily the bug to watch to detect the default being switched on.

I'll land the patch to re-enable the feature to Bug 1454204 once all of it's dependencies have landed.  Please check there for updated progress.
Flags: needinfo?(kgilbert)
See Also: → 1476090
You need to log in before you can comment on or make changes to this bug.