Closed Bug 1459563 Opened 2 years ago Closed 2 years ago

page number field in print preview dialog is too wide

Categories

(Toolkit :: Printing, defect, P3)

All
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- fixed
firefox59 --- unaffected
firefox60 --- wontfix
firefox61 --- fixed
firefox62 --- fixed

People

(Reporter: aceman, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

In print preview dialog, the current page number field is too wide now (from what it was before 60). It now has space for about 10 digits (insane for number of print pages), while it was 3-4 before.
Possibly caused by bug 1429573 too and not fixed by bug 1437302. It is still seen in Firefox nightly.
Also seen in Thunderbird as the dialog is shared.
Hey aceman, is this Linux only? I'm not able to see the issue on Windows (https://imgur.com/dLOiJde)
Flags: needinfo?(acelists)
Tentatively marking this as Linux-only. Please re-set if anybody is seeing this on Windows too.
OS: All → Linux
Hey paolo, could this be fallout from bug 1429573 / bug 1437302, as aceman suggests?
Flags: needinfo?(paolo.mozmail)
Priority: -- → P3
Attached patch Bug1459563.patch (obsolete) — Splinter Review
Bug 1437302 didn't set the width of this field on Linux, only for Windows.

I added 3ch more because the linux uses wider borders than Windows.

Aceman, can you try this patch as Mike probably has no Linux.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(paolo.mozmail)
Attachment #8973745 - Flags: review?(mconley)
Attachment #8973745 - Flags: feedback?(acelists)
Comment on attachment 8973745 [details] [diff] [review]
Bug1459563.patch

Review of attachment 8973745 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this works for me. There is now space exactly for 3 digits.
Attachment #8973745 - Flags: feedback?(acelists) → feedback+
Julien, are you sure that you don't want to fix FF 60 ESR with a simple CSS tweak? No risk, and it looks bad in a version that will live for a year.
Flags: needinfo?(acelists) → needinfo?(jcristau)
Comment on attachment 8973745 [details] [diff] [review]
Bug1459563.patch

Yes, this looks much better. Thanks, Paenglab!
Attachment #8973745 - Flags: review?(mconley) → review+
Attached patch Bug1459563.patchSplinter Review
This one calculated the field width with the padding on each side and a border of 6px (this depends on the Linux theme but most use 6px).
Attachment #8973745 - Attachment is obsolete: true
Attachment #8973793 - Flags: review?(mconley)
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b006cfda5d9e
Set also on Linux a width of the page number field in print preview dialog. r=mconley
Keywords: checkin-needed
Comment on attachment 8973793 [details] [diff] [review]
Bug1459563.patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1429573 
[User impact if declined]: Ugly page number field in print preview
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: No.
[Is the change risky?]: Not risky, just a few lines of CSS defining a width for the field.
[Why is the change risky/not risky?]: See above.
[String changes made/needed]: None.
Flags: needinfo?(jcristau)
Attachment #8973793 - Flags: approval-mozilla-esr60?
Attachment #8973793 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/b006cfda5d9e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Comment on attachment 8973793 [details] [diff] [review]
Bug1459563.patch

Simple CSS fix, approved for 61.0b4. We'll look at the ESR60 request later in the cycle.
Attachment #8973793 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8973793 [details] [diff] [review]
Bug1459563.patch

fix print preview regression in 60.1esr
Attachment #8973793 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
You need to log in before you can comment on or make changes to this bug.