Error in rendering when using javascript with the .disable property

RESOLVED DUPLICATE of bug 112113

Status

()

RESOLVED DUPLICATE of bug 112113
17 years ago
11 years ago

People

(Reporter: lordvan, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020519
BuildID:    2002051918

rendering error if i try to close a 'subtree' of the menu the subtree isn't
visible any more, but there is white space any more only if u close and open the
parent tree the error isn't present any more

Reproducible: Always
Steps to Reproduce:
1.click on the graphic (the +) to open the tree
2.open 2nd sub-tree
3.then close 2nd sub-tree again

Actual Results:  white space between the subtree 2 and 3

Expected Results:  remove the whitespace too and not only the content that was
in there
That code seems to be setting table rows to display:block instead of
display:table-row....

Is that correct? 
(Reporter)

Comment 2

17 years ago
well it 's not correct i suppose, but it's working in IE5/6 ;)
but u r right that would be the correct way i'll change it
but anyway is it meant that if u assign a wrong type there is whitespace when u
remove it again?

btw IE doesn't know table-row ... so i have to add browser-checking here too?!?!?
Well.. you create a block inside a table.  This is not allowed, so some weird
anonymous box creation has to happen (create an anonymous table row, table cell,
put the block in that table cell).  Then you hide the block, but the row/cell
are still there.

If you are using actual <tr> elements, setting display to "" will work in both
IE and Mozilla.

In IE, table rows _are_ blocks, because it does not support display:table-row at
all.  That's why this works there... (and IE has other issues associated with this).

*** This bug has been marked as a duplicate of 112113 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: desale → stummala

Updated

11 years ago
Component: DOM: Views and Formatting → DOM: CSS Object Model
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.