Closed Bug 14600 Opened 21 years ago Closed 21 years ago

[BLOCKER][PP]Apprunner crashes after migrating a profile or creating a new profile

Categories

(SeaMonkey :: General, defect, P1, blocker)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 14775

People

(Reporter: agracebush, Assigned: sspitzer)

Details

Steps to reproduce:
1. delete mozregistry
2. delete documents folder containing old profiles
3. run either apprunner  or Mozilla Installer
4. choose either migrate 4.x profile or create new (and enter data for new
profile)

Actual results: migration progress window appears, apprunner menu appears, crash
and system literally pings until it hangs, requiring reboot
profile does get migrated and/or created and is usable on 2nd launch

Expected results: apprunner launch using the migrated or created profile

Mac only PPC 8.5

I don't think it is a profile issue but cc Bhuvan and Steve fyi
Severity: normal → blocker
Priority: P3 → P1
Summary: [PP]Apprunner crashes after migrating a profile or creating a new profile → [BLOCKER][PP]Apprunner crashes after migrating a profile or creating a new profile
Marking as blocker on Mac
If you have more than one profile, you cannot launch apprunner at all. Clicking
on apprunner takes you to ProfileManager, selecting any of multiple profiles and
pressing start causes a crash, sometimes a reboot
Mail/news not able to test POP and IMAP accounts without removing and
remigrating separate accounts.
here's a stack trace for the mac:

  00000000    PPC  062E89C0
  06CC8C00    PPC  062E5CCC  main+00114
  06CC8B90    PPC  062E56C8  main1(int, char**)+00360
  06CC8A10    PPC  05EF0DA8
nsProfile::StartupWithArgs(nsICmdLineService*)+00080
  06CC89B0    PPC  05EF10B4  nsProfile::LoadDefaultProfileDir(char*)+00288
  06CC88C0    PPC  0621B64C  nsAppShellService::Run()+00018
  06CC8880    PPC  060AA780  nsAppShell::Run()+00038
  06CC8800    PPC  060AB274  nsMacMessagePump::DoMessagePump()+0003C
  06CC87B0    PPC  060AB4E8  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+00114
  06CC8760    PPC  060ABD08  nsMacMessagePump::DoMouseMove(EventRecord&)+0004C
  06CC8710    PPC  060AC13C
nsMacMessagePump::DispatchOSEventToRaptor(EventRecord&, GrafPort
*)+00044
  06CC86C0    PPC  060A6154  nsMacMessageSink::DispatchOSEvent(EventRecord&,
GrafPort*)+00038
  06CC8680    PPC  060A0A44  nsMacWindow::HandleOSEvent(EventRecord&)+00020
  06CC8620    PPC  060A0F60
nsMacEventHandler::HandleOSEvent(EventRecord&)+00128
this occurs on both mozilla and netscape builds
Assignee: don → davidm
re-assign to davidm.

perhaps its somehow related to the splash screen?

anyone know how I turn that off?
Comment out the 2 lines ShowSplashScreen and hideSplashscreen in
nsApprunner.cpp.
no, i think what seth was asking was how does he make the splash screen go away.

it appears we get into a code path with the "create new profile" dialog that

bypasses the normal path so the splash screen never goes away. the main window

never appears either, but we still manager to get to the main event loop.
when I comment out the two lines, I don't crash.

but I just sit there after profile window goes away and spin, with
WaitNextEvent() on top of the stack.

Won't some brave mac warrior step up and fix this?
ok, we have a candidate fix.

the problem appears to be caused by the code that allows you to close all
windows and not quit the app.  (only on mac.)

fix bug davidm.

seeking check in approval now.

seeking approval too.
I think the correct fix is to replace the calls to toolkit.CloseWindow with
	// Need to call this to stop the event loop
 	var appShell = Components.classes['component://netscape/appshell/
appShellService'].getService();
 	appShell = appShell.QueryInterface( Components.interfaces.nsIAppShellService);
	appShell.Quit();
I'll try that out and report back later today.
Target Milestone: M11
actually, davidm, feel free to come and try that out on my iMac.
Assignee: davidm → sspitzer
taking back from davidm.

I'm going to be working on all things related to profile in the next couple
weeks, so I'll take this bug.

I may need some help from davidm, so adding him to the cc list.
Seth,

Something that Jimmy and I have noticed on this bug...on either create new  or
migrate profile, the action appears to take place and apprunner menu shows on
top of screen but no window.  Move the mouse and crash. Stack crawl looks the
same as the one here.
Target Milestone: M11 → M10
This is a definite blocker.  Moving to M10.
I am pretty sure that above is the right fix on the mac. Can't check on windows
since another bug is causing crashes.
david's fix is making things better for me on the mac, and it plays nice on UNIX
too.

after I check windows, I'll check it in.
I've checked in davidm's javascript, and a fix of my own into nsProfile.cpp.

there still seems to be bugs lurking.  see #14775, which is assigned to pierre.

there was also traffic on the layout newsgroup about a related crasher.
Status: NEW → ASSIGNED
ignoring #14775, you can use multiple profiles on the mac.

I hesitate to mark this fixed until its crash proof, though.

accepting.
I don't understand your last comments. This bug should be marked as a duplicate
of 14775.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 14775 ***
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.