Closed Bug 1460150 Opened 2 years ago Closed 2 years ago

Intermittent w3c-css/received/css-writing-modes/text-orientation-016.xht == w3c-css/received/css-writing-modes/text-orientation-016-ref.xht | image comparison, max difference: 255, number of differing pixels: 1920

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1392106

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=177590090&repo=autoland

https://queue.taskcluster.net/v1/task/dPDn9qVKRmisfkT9dBnO5w/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/dPDn9qVKRmisfkT9dBnO5w/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

02:20:44     INFO -  REFTEST TEST-START | file:///Z:/task_1525831166/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-orientation-016.xht == file:///Z:/task_1525831166/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-orientation-016-ref.xht
02:20:44     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1525831166/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-orientation-016.xht | 877 / 921 (95%)
02:20:44     INFO -  ++DOMWINDOW == 72 (0E028800) [pid = 5068] [serial = 2079] [outer = 05FBA540]
02:20:44     INFO -  Could not create glyph run analysis.
02:20:44     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(498) : error 0x80070005: Access is denied.
02:20:44     INFO -  Requested bounding box could not be determined.
02:20:44     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(581) : error 0x80070005: Access is denied.
02:20:44     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1525831166/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-orientation-016-ref.xht | 877 / 921 (95%)
02:20:44     INFO -  ++DOMWINDOW == 73 (0E844000) [pid = 5068] [serial = 2080] [outer = 05FBA540]
02:20:44     INFO -  REFTEST INFO | REFTEST fuzzy test (0, 0) <= (255, 1920) <= (226, 960)
02:20:44    ERROR -  REFTEST TEST-UNEXPECTED-FAIL | file:///Z:/task_1525831166/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-orientation-016.xht == file:///Z:/task_1525831166/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-orientation-016-ref.xht | image comparison, max difference: 255, number of differing pixels: 1920
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
The recent log that presumably triggered the reopening was this one from today:
https://treeherder.mozilla.org/logviewer.html#?job_id=189932293&repo=mozilla-central&lineNumber=49663

I took a look -- the testcase is missing some of the yellow rectangles. The yellow rectangles are actually text (in the blocky Ahem font), so this is missing letters, and it's on Windows 7 --> dupe of bug 1392106
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: missing-letter-win7
You need to log in before you can comment on or make changes to this bug.