Closed Bug 1460169 Opened 2 years ago Closed 2 years ago

Intermittent PROCESS-CRASH | dom/tests/mochitest/gamepad/test_gamepad_connect_events.html | application crashed [@ TimerThread::Run()] | after Assertion failure: rc != 0 (destroyed timer off its target thread!), at z:/build

Categories

(Core :: DOM: Device Interfaces, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1334383

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=177537394&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/NeBWpUSZQ5K-gLdkt6WuKg/runs/0/artifacts/public/logs/live_backing.log

20:04:52     INFO -  5878 INFO TEST-START | dom/tests/mochitest/gamepad/test_check_timestamp.html
20:04:52     INFO -  GECKO(3704) | ++DOMWINDOW == 7 (0CB71800) [pid = 5676] [serial = 7] [outer = 05EB7410]
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 8 (07CD7000) [pid = 5676] [serial = 8] [outer = 05EB7410]
20:04:53     INFO -  GECKO(3704) | ++DOCSHELL 05E31C00 == 3 [pid = 5676] [id = {1cb23a42-1500-448e-8347-8aec3185cec4}]
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 9 (05EB7540) [pid = 5676] [serial = 9] [outer = 00000000]
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 10 (07CDC800) [pid = 5676] [serial = 10] [outer = 05EB7540]
20:04:53     INFO -  GECKO(3704) | --DOMWINDOW == 9 (0CB69C00) [pid = 5676] [serial = 6] [outer = 00000000] [url = about:blank]
20:04:53     INFO -  GECKO(3704) | --DOMWINDOW == 8 (05E3D400) [pid = 5676] [serial = 2] [outer = 00000000] [url = about:blank]
20:04:53     INFO -  GECKO(3704) | MEMORY STAT | vsize 486MB | vsizeMaxContiguous 663MB | residentFast 78MB | heapAllocated 9MB
20:04:53     INFO -  5879 INFO TEST-OK | dom/tests/mochitest/gamepad/test_check_timestamp.html | took 1379ms
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 9 (0D235C00) [pid = 5676] [serial = 11] [outer = 05EB7410]
20:04:53     INFO -  5880 INFO None5881 INFO TEST-START | dom/tests/mochitest/gamepad/test_gamepad.html
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 10 (07CD6400) [pid = 5676] [serial = 12] [outer = 05EB7410]
20:04:53     INFO -  GECKO(3704) | ++DOCSHELL 0143C400 == 4 [pid = 5676] [id = {c383c818-3e53-41ce-9b20-ff6cbbe45717}]
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 11 (05EB7670) [pid = 5676] [serial = 13] [outer = 00000000]
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 12 (0D236400) [pid = 5676] [serial = 14] [outer = 05EB7670]
20:04:53     INFO -  GECKO(3704) | MEMORY STAT | vsize 487MB | vsizeMaxContiguous 662MB | residentFast 79MB | heapAllocated 10MB
20:04:53     INFO -  5882 INFO TEST-OK | dom/tests/mochitest/gamepad/test_gamepad.html | took 201ms
20:04:53     INFO -  GECKO(3704) | ++DOMWINDOW == 13 (0D235000) [pid = 5676] [serial = 15] [outer = 05EB7410]
20:04:53     INFO -  5883 INFO None5884 INFO TEST-START | dom/tests/mochitest/gamepad/test_gamepad_connect_events.html
20:04:54     INFO -  GECKO(3704) | Assertion failure: rc != 0 (destroyed timer off its target thread!), at z:/build/build/src/xpcom/threads/TimerThread.cpp:480
20:05:06     INFO -  GECKO(3704) | #01: TimerThread::Run() [xpcom/threads/TimerThread.cpp:414]
20:05:06     INFO -  GECKO(3704) | #02: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1093]
20:05:06     INFO -  GECKO(3704) | #03: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:519]
20:05:06     INFO -  GECKO(3704) | #04: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:364]
20:05:06     INFO -  GECKO(3704) | #05: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:326]
20:05:06     INFO -  GECKO(3704) | #06: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:320]
20:05:06     INFO -  GECKO(3704) | #07: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:300]
20:05:06     INFO -  GECKO(3704) | #08: nsThread::ThreadFunc(void *) [xpcom/threads/nsThread.cpp:427]
20:05:07     INFO -  GECKO(3704) | #09: _PR_NativeRunThread [nsprpub/pr/src/threads/combined/pruthr.c:397]
20:05:07     INFO -  GECKO(3704) | #10: static unsigned int pr_root(void *) [nsprpub/pr/src/md/windows/w95thred.c:137]
20:05:07     INFO -  GECKO(3704) | #11: ucrtbase.DLL + 0x3e89f
20:05:07     INFO -  GECKO(3704) | #12: kernel32.dll + 0x53c45
20:05:07     INFO -  GECKO(3704) | #13: static void patched_BaseThreadInitThunk(int, void *, void *) [mozglue/build/WindowsDllBlocklist.cpp:858]
20:05:07     INFO -  GECKO(3704) | #14: ntdll.dll + 0x637f5
20:05:07     INFO -  GECKO(3704) | #15: ntdll.dll + 0x637c8
20:05:07     INFO -  TEST-INFO | Main app process: exit 1
20:05:07     INFO -  Buffered messages finished
20:05:07    ERROR -  5885 ERROR TEST-UNEXPECTED-FAIL | dom/tests/mochitest/gamepad/test_gamepad_connect_events.html | application terminated with exit code 1
20:05:07     INFO -  runtests.py | Application ran for: 0:00:21.043000
20:05:07     INFO -  zombiecheck | Reading PID log: c:\users\task_1525806445\appdata\local\temp\tmpa2pv4ipidlog
20:05:07     INFO -  ==> process 3704 launched child process 4660 ("Z:\task_1525806445\build\application\firefox\firefox.exe" -contentproc --channel="3704.0.41601762\1512922810" -childID 1 -isForBrowser -prefsHandle 1708 -prefsLen 16548 -schedulerPrefs 0001,2 -parentBuildID 20180508183034 -greomni "Z:\task_1525806445\build\application\firefox\omni.ja" -appomni "Z:\task_1525806445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1525806445\build\application\firefox\browser" - 3704 "\\.\pipe\gecko-crash-server-pipe.3704" 1772 tab)
20:05:07     INFO -  ==> process 3704 launched child process 5676 ("Z:\task_1525806445\build\application\firefox\firefox.exe" -contentproc --channel="3704.6.1190821968\2043509517" -childID 2 -isForBrowser -prefsHandle 2068 -prefsLen 16548 -schedulerPrefs 0001,2 -parentBuildID 20180508183034 -greomni "Z:\task_1525806445\build\application\firefox\omni.ja" -appomni "Z:\task_1525806445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1525806445\build\application\firefox\browser" - 3704 "\\.\pipe\gecko-crash-server-pipe.3704" 2084 tab)
20:05:07     INFO -  ==> process 3704 launched child process 4520 ("Z:\task_1525806445\build\application\firefox\firefox.exe" -contentproc --channel="3704.12.778444530\534344319" -childID 3 -isForBrowser -prefsHandle 2316 -prefsLen 17892 -schedulerPrefs 0001,2 -parentBuildID 20180508183034 -greomni "Z:\task_1525806445\build\application\firefox\omni.ja" -appomni "Z:\task_1525806445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1525806445\build\application\firefox\browser" - 3704 "\\.\pipe\gecko-crash-server-pipe.3704" 2328 tab)
20:05:07     INFO -  zombiecheck | Checking for orphan process with PID: 4520
20:05:07     INFO -  zombiecheck | Checking for orphan process with PID: 5676
20:05:07     INFO -  zombiecheck | Checking for orphan process with PID: 4660
20:05:07     INFO -  mozcrash Copy/paste: Z:\task_1525806445\build\win32-minidump_stackwalk.exe c:\users\task_1525806445\appdata\local\temp\tmpmtlplh.mozrunner\minidumps\2c87c6cf-5b81-4eb4-86ee-b8ea2272482f.dmp Z:\task_1525806445\build\symbols
20:05:27     INFO -  mozcrash Saved minidump as Z:\task_1525806445\build\blobber_upload_dir\2c87c6cf-5b81-4eb4-86ee-b8ea2272482f.dmp
20:05:27     INFO -  mozcrash Saved app info as Z:\task_1525806445\build\blobber_upload_dir\2c87c6cf-5b81-4eb4-86ee-b8ea2272482f.extra
20:05:27  WARNING -  PROCESS-CRASH | dom/tests/mochitest/gamepad/test_gamepad_connect_events.html | application crashed [@ TimerThread::Run()]
20:05:27     INFO -  Crash dump filename: c:\users\task_1525806445\appdata\local\temp\tmpmtlplh.mozrunner\minidumps\2c87c6cf-5b81-4eb4-86ee-b8ea2272482f.dmp
20:05:27     INFO -  Operating system: Windows NT
20:05:27     INFO -                    6.1.7601 Service Pack 1
20:05:27     INFO -  CPU: x86
20:05:27     INFO -       GenuineIntel family 6 model 63 stepping 2
20:05:27     INFO -       8 CPUs
20:05:27     INFO -  GPU: UNKNOWN
20:05:27     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
20:05:27     INFO -  Crash address: 0x565dec5b
20:05:27     INFO -  Process uptime: 8 seconds
20:05:27     INFO -  Thread 17 (crashed)
20:05:27     INFO -   0  xul.dll!TimerThread::Run() [TimerThread.cpp:ce4fdee191230038af2188d9c9ed1ee126fa551f : 414 + 0x18]
20:05:27     INFO -      eip = 0x565dec5b   esp = 0x0d33f018   ebp = 0x0d33f0ac   ebx = 0x0d33f644
20:05:27     INFO -      esi = 0x000001e0   edi = 0x00000000   eax = 0x00000000   ecx = 0x68f9c911
20:05:27     INFO -      edx = 0x00000000   efl = 0x00000216
20:05:27     INFO -      Found by: given as instruction pointer in context
20:05:27     INFO -   1  xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:ce4fdee191230038af2188d9c9ed1ee126fa551f : 1090 + 0x11]
20:05:27     INFO -      eip = 0x565dc111   esp = 0x0d33f0b4   ebp = 0x0d33f638
20:05:27     INFO -      Found by: call frame info
20:05:27     INFO -   2  ntdll.dll!RtlpAllocateHeap + 0x2e7
20:05:27     INFO -      eip = 0x76fa5dd3   esp = 0x0d33f0f4   ebp = 0x0d33f638
20:05:27     INFO -      Found by: stack scanning
20:05:27     INFO -   3  xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:ce4fdee191230038af2188d9c9ed1ee126fa551f : 519 + 0xd]
20:05:27     INFO -      eip = 0x565e4947   esp = 0x0d33f640   ebp = 0x0d33f664
20:05:27     INFO -      Found by: call frame info
20:05:27     INFO -   4  xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [MessagePump.cpp:ce4fdee191230038af2188d9c9ed1ee126fa551f : 364 + 0xa]
20:05:27     INFO -      eip = 0x569deacb   esp = 0x0d33f66c   ebp = 0x0d33f688
20:05:27     INFO -      Found by: call frame info
20:05:27     INFO -   5  xul.dll!MessageLoop::RunInternal() [message_loop.cc:ce4fdee191230038af2188d9c9ed1ee126fa551f : 326 + 0xf]
20:05:27     INFO -      eip = 0x569b7561   esp = 0x0d33f690   ebp = 0x0d33f6a8
20:05:27     INFO -      Found by: call frame info
Summary: Intermittent GECKO(3704) | Assertion failure: rc != 0 (destroyed timer off its target thread!), at z:/build/build/src/xpcom/threads/TimerThread.cpp:480 → Intermittent PROCESS-CRASH | dom/tests/mochitest/gamepad/test_gamepad_connect_events.html | application crashed [@ TimerThread::Run()] | after Assertion failure: rc != 0 (destroyed timer off its target thread!), at z:/build
Component: XPCOM → DOM: Device Interfaces
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334383
You need to log in before you can comment on or make changes to this bug.