Closed Bug 1460387 Opened 5 years ago Closed 3 years ago

Form on cncf.io blank with tracking protection enabled

Categories

(Web Compatibility :: Desktop, defect, P5)

Firefox 61
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: adamopenweb, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: tp-ads)

User Story

pardot.com

Attachments

(1 file)

Originally Reported:
https://github.com/webcompat/web-bugs/issues/16789

Steps to reproduce:
1) Enable tracking protection
2) Navigate to https://www.cncf.io/about/join/
3) Scroll down

Expected behavior:
Should be a form there to fill out

Actual behavior:
Form area is blank

Issue only occurs with Tracking Protection enabled.

Resource blocked:
https://go.pardot.com/l/6342/2015-07-17/2n4337

Pardot on block list:
https://github.com/mozilla-services/shavar-prod-lists/blob/master/disconnect-blacklist.json#L4174

Looks like Pardot is a Salesforce product.
Attached image Screenshot of issue
Thanks for all of the details Adam!

(In reply to Adam Stevenson [:adamopenweb] from comment #0)
> Pardot on block list:
> https://github.com/mozilla-services/shavar-prod-lists/blob/master/disconnect-
> blacklist.json#L4174

That entry is in the "Advertising" category.
Component: Tracking Protection → Desktop
Product: Firefox → Tech Evangelism
Whiteboard: tp-base
Version: 61 Branch → Firefox 61
Thanks Francois. What are the next steps here? I'd be surprised if the website wants to change the form. Pardot is possibly integrated with other systems they use.
(In reply to Adam Stevenson [:adamopenweb] from comment #3)
> Thanks Francois. What are the next steps here? I'd be surprised if the
> website wants to change the form. Pardot is possibly integrated with other
> systems they use.

You could send feedback to Disconnect: https://disconnect.me/trackerprotection

and it's possible they'd consider classifying this in the "content" category, which is not enabled by default.

A work-around for the site would be to link to the form itself. We don't block it if it's the top-level URL.

   "Form not displaying? Click here to fill it out."
Priority: -- → P5
User Story: (updated)
Whiteboard: tp-base → tp-ads
Product: Tech Evangelism → Web Compatibility

I think this is not reproducible now. Is that right?

The form seems fine now in strict mode, even if other resources are still being blocked.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.