Closed Bug 1460591 Opened 2 years ago Closed 2 years ago

Intermittent /html/semantics/embedded-content/media-elements/interfaces/TextTrackCue/constructor.html | pop from empty list

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1460526

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered])

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=177843113&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/PE2BZc3WSq26eKH_6YPYUQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-05-10T11:42:10.283Z] 11:42:10     INFO - TEST-START | /html/semantics/embedded-content/media-elements/interfaces/TextTrackCue/constructor.html
[task 2018-05-10T11:42:10.283Z] 11:42:10     INFO - PID 9395 | A content process crashed and MOZ_CRASHREPORTER_SHUTDOWN is set, shutting down
[task 2018-05-10T11:42:10.421Z] 11:42:10  WARNING - Traceback (most recent call last):
[task 2018-05-10T11:42:10.421Z] 11:42:10  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 464, in _run
[task 2018-05-10T11:42:10.422Z] 11:42:10  WARNING -     self.result = True, self.func(self.protocol, self.url, self.timeout)
[task 2018-05-10T11:42:10.423Z] 11:42:10  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 531, in do_testharness
[task 2018-05-10T11:42:10.423Z] 11:42:10  WARNING -     parent_window = protocol.testharness.close_old_windows(protocol)
[task 2018-05-10T11:42:10.424Z] 11:42:10  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 151, in close_old_windows
[task 2018-05-10T11:42:10.425Z] 11:42:10  WARNING -     runner_handle = handles.pop(0)
[task 2018-05-10T11:42:10.425Z] 11:42:10  WARNING - IndexError: pop from empty list
[task 2018-05-10T11:42:10.425Z] 11:42:10  WARNING - 
[task 2018-05-10T11:42:10.461Z] 11:42:10     INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/aqCXxb4tTzWn2pk6yG3TCQ/artifacts/public/build/target.crashreporter-symbols.zip
[task 2018-05-10T11:42:10.526Z] 11:42:10     INFO - PID 9395 | *** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping
[task 2018-05-10T11:42:15.924Z] 11:42:15     INFO - mozcrash Copy/paste: /usr/local/bin/linux64-minidump_stackwalk /tmp/tmpYNydnz.mozrunner/minidumps/51834ee2-4021-4752-a7bc-4473700cbb30.dmp /tmp/tmpveslL5
[task 2018-05-10T11:42:23.338Z] 11:42:23     INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/51834ee2-4021-4752-a7bc-4473700cbb30.dmp
[task 2018-05-10T11:42:23.338Z] 11:42:23     INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/51834ee2-4021-4752-a7bc-4473700cbb30.extra
[task 2018-05-10T11:42:23.461Z] 11:42:23     INFO - TEST-UNEXPECTED-ERROR | /html/semantics/embedded-content/media-elements/interfaces/TextTrackCue/constructor.html | pop from empty list
[task 2018-05-10T11:42:23.461Z] 11:42:23     INFO - TEST-INFO took 13219ms
[task 2018-05-10T11:42:23.463Z] 11:42:23     INFO - Browser exited with retur
Matt, seems the patches for bug 1452464 may have caused a problem here.
Blocks: 1452464
Flags: needinfo?(overholt) → needinfo?(matt.woodrow)
Indeed they have! Looks like this is a duplicate of bug 1460526, I have a patch there.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → DUPLICATE
Duplicate of bug: 1460526
No longer blocks: 1452464
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.