Closed Bug 1460748 Opened 2 years ago Closed 2 years ago

WebExtension dictionaries load .dic file as affix file

Categories

(Toolkit :: Add-ons Manager, defect)

62 Branch
x86_64
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla62
Tracking Status
firefox-esr60 65+ verified
firefox62 --- verified

People

(Reporter: github, Assigned: kmag)

References

Details

(Keywords: nightly-community)

Attachments

(4 files)

Attached image 2018-05-09.png
I noticed that that beginning with the 2018-05-10 builds the spell checking has some issues as it marks correct words wrong and suggest wrong alternatives. Please see the two screenshots for the differences between the 2018-05-10 and the 2018-05-09 build. I installed both time the same dictionary (https://addons.mozilla.org/en-US/firefox/addon/german-dictionary-de_ch-for-sp/) and also tested it with a fresh profile. I'm using macOS 10.13.3
Attached image 2018-05-10.png
Blocks: 1457072, 1457321
I'm marking the blocks because those are the two last changes on the dictionaries/spell check. Also ping Kris as the assignee of those bugs.
Flags: needinfo?(kmaglione+bmo)
No longer blocks: 1457321
Assignee: nobody → kmaglione+bmo
Status: UNCONFIRMED → NEW
Component: Spelling checker → Add-ons Manager
Ever confirmed: true
Flags: needinfo?(kmaglione+bmo)
Product: Core → Toolkit
Summary: Spell checking makes wrong suggestions and mark wrong words → WebExtension dictionaries load .dic file as affix file
Comment on attachment 8974853 [details]
Bug 1460748: Load the correct affix file for WebExtension dictionaries.

https://reviewboard.mozilla.org/r/243232/#review249350

A comment in mozISpellCheckingEngine.idl indicating that `addDictionary()` takes the .aff file and derives the location of the .dic file from it would make this all marginally less obscure...
Attachment #8974853 - Flags: review?(aswan) → review+
Comment on attachment 8974853 [details]
Bug 1460748: Load the correct affix file for WebExtension dictionaries.

https://reviewboard.mozilla.org/r/243232/#review249350

Fixed.
https://hg.mozilla.org/integration/mozilla-inbound/rev/c617698f9edfa167bcae2babe7e68d77c47b3d68
Bug 1460748: Load the correct affix file for WebExtension dictionaries. r=aswan
tested with 2018-05-13 build; result is the same as in 2018-05-09.png screenshot. Bug is fixed.
Status: RESOLVED → VERIFIED
Blocks: 1513926
Comment on attachment 8974853 [details]
Bug 1460748: Load the correct affix file for WebExtension dictionaries.

[ESR Uplift Approval Request]

If this is not a sec:{high,crit} bug, please state case for ESR consideration: This makes dictionaries more or less useless for users who it affects

User impact if declined: AMO only distributes WebExtension dictionaries at this point, and those dictionaries currently do not work properly in ESR. Stem words are detected correctly, but affixes are ignored.

Fix Landed on Version: 62

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It's a trivial change to load the correct affix file when loading dictionaries. The change has been present in release builds for several versions, and only has the potential to affect dictionaries which are already not working correctly.

String or UUID changes made by this patch: None.
Attachment #8974853 - Flags: approval-mozilla-esr60?
No longer blocks: 1513926
Duplicate of this bug: 1513926
Comment on attachment 8974853 [details]
Bug 1460748: Load the correct affix file for WebExtension dictionaries.

make webextension dictionaries work, approved for 60.5.0esr
Attachment #8974853 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
This needs a rebased patch for ESR60.
Flags: needinfo?(kmaglione+bmo)
I was able to reproduce this issue on Firefox 60.4.0esr(20181203164059) under Win 7 64-bit and  Mac OS X 10.14.1.

This issue is verified as fixed on Firefox 60.4.1esr(20190104225443) Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached screenshot.
Attached image Bug1460748Fixed.png
You need to log in before you can comment on or make changes to this bug.