browser_parsable_css.js | Got error message for resource://pdf.js/web/viewer.css when Gecko 62 merges to Beta on 2018-06-14

VERIFIED FIXED in Firefox 62

Status

()

defect
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: ebalazs_, Assigned: xidorn)

Tracking

({regression})

unspecified
mozilla62
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=bed328ba3d401474c773891f7a76dcae6ac56a41&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable

This is a regression from bug 509958.

browser/base/content/test/static/browser_parsable_css.js | Got error message for resource://pdf.js/web/viewer.css: Unknown pseudo-class or pseudo-element ‘fullscreen’. Ruleset ignored due to bad selector. -
Flags: needinfo?(emilio)
(Assignee)

Comment 1

a year ago
:fullscreen is an invalid pseudo-class in beta, but valid for chrome stylesheet. That should have been the case for a while. Why could a change to ::selection regress this?
(Assignee)

Comment 2

a year ago
Also this whitelist item in browser_parsable_css.js:
> // PDFjs is futureproofing its pseudoselectors, and those rules are dropped.
> {sourceName: /web\/viewer\.css$/i,
>  errorMessage: /Unknown pseudo-class.*(fullscreen|selection)/i,
>  isFromDevTools: false},
should silence this error message.
(Assignee)

Comment 4

a year ago
Unprefixed fullscreen has been enabled in nightly (but not beta), so before bug 509958, only the "selection" part was used in the whitelist item, and thus after that bug, that whitelist item doesn't catch anything and became useless, so emilio removed it.

However, unprefixed fullscreen still isn't enabled on beta and release, so without that whitelist item, this would be a problem.

I guess the fix would be to push that whitelist item conditionally according to whether unprefixed fullscreen is around.
(Assignee)

Updated

a year ago
Assignee: nobody → xidorn+moz
Flags: needinfo?(emilio)

Comment 7

a year ago
mozreview-review
Comment on attachment 8975000 [details]
Bug 1460870 - Whitelist fullscreen pseudo-class in pdfjs when unprefixed fullscreen is disabled.

https://reviewboard.mozilla.org/r/243384/#review249238
Attachment #8975000 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 8

a year ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87df7799c295
Whitelist fullscreen pseudo-class in pdfjs when unprefixed fullscreen is disabled. r=Gijs
Tracking for 62, though this will likely be fixed on m-c before it comes up again in triage.
https://hg.mozilla.org/mozilla-central/rev/87df7799c295
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Keywords: regression
You need to log in before you can comment on or make changes to this bug.