Closed Bug 1460905 Opened 2 years ago Closed 2 years ago

Tab loaded in background wont paint unless you move mouse inside the page from the tab-bar

Categories

(Core :: Graphics: Layers, defect, major)

62 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified

People

(Reporter: mayankleoboy1, Unassigned)

References

Details

(Keywords: nightly-community, regression, reproducible, Whiteboard: [fixed by patch backout from bug #1176019])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180511100427

Steps to reproduce:

1. create new nightly profile
2. Open google.com in tab1
3. Open https://bugzilla.mozilla.org/page.cgi?id=user_activity.html&action=run&from=-14d&who=jdemooij%40mozilla.com in a new tab (tab2)
4. Scroll to the bottom. there is a link in the bottom left saying "show as a bug list"
5. click on that link, AND IMMEDIATELY switch to tab1

6. Let the tab2 load
7. Switch to tab2 by clicking mouse on the tab2 in tab-bar


Actual results:

page doesnt paint unless you move the mouse inside the tab


Expected results:

not so

Regression: 
Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=31b295f557db579744feb07900a5aa5e145452b0&full=1
2018-05-11T21:16:42: DEBUG : Found commit message:
Bug 1176019 - Fix browser_tabswitchbetweenplugins.js r=mconley

After digging into this, I'm still not entirely sure why the timing
has changed such that the checks don't work immediately. I have a
strong suspicion though that it's simply because our tab switch is
now instant, resulting in the necessary messages just being a
little bit behind. Hopefully this is an acceptable bandaid.

MozReview-Commit-ID: H1wKW1UQBxp

2018-05-11T21:16:42: INFO : The bisection is done.
2018-05-11T21:16:42: INFO : Stopped
Blocks: 1176019
it could be that tab2 should load in background in step 3. As in, paste+enter the url in the urlbar, then seitch to the tab1 while it loads
Summary: Tab wont paint unless you move mouse inside the page → Tab loaded in background wont paint unless you move mouse inside the page from the tab-bar
Severity: normal → major
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(dothayer)
Version: Trunk → 62 Branch
Bug 1176019 was backed out - whatever fix we come up with for this will be included in the patches for that bug. Is resolving as fixed by the backout all right?
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dothayer)
Resolution: --- → FIXED
Sure. Thanks for looking.
Status: RESOLVED → VERIFIED
Whiteboard: [fixed by patch backout from bug #1176019]
You need to log in before you can comment on or make changes to this bug.