Can't start - java plugin proxy configuration

VERIFIED DUPLICATE of bug 83376

Status

defect
--
critical
VERIFIED DUPLICATE of bug 83376
17 years ago
15 years ago

People

(Reporter: nl, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; 
APC; .NET CLR 1.0.2914)
BuildID:    20020522 (? Mozilla 1.0 RC2)

I upgraded from a previous Mozilla build (Something around build 20020325) to 
Mozilla 1.0 RC2. Now when I try and startup I get an error dialog titled:

"Java Plugin Configuration Warning"

With the text in it:

"Unable to obtain proxy configuration from Netscape Navigator 3.x - fallback."

I press the okay button, an Mozilla crashes (I get the Netscape talkback thing).

I have the Java 1.3 Plugin installed.

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla
2.Crash
3.

Expected Results:  Mozilla should startup

Not sure what will help...

java -showversion gives:

Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1-b24)
Java HotSpot(TM) Client VM (build 1.3.1-b24, mixed mode)

I've tried setting the java proxies specifically (ie, not "using browser 
settings") in the Java plugin configuration control panel applet.
(Reporter)

Comment 1

17 years ago
It appears this is realted to having a custom user-agent set. If I have the 
line "user_pref("general.useragent.override", "Custom Mozilla");" in my 
prefs.js file it crashes, and if  comment it out it runs correctly.

I think it is probably related to bug 83376, although the error message is 
different.


*** This bug has been marked as a duplicate of 83376 ***
Severity: blocker → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.