Closed Bug 1461010 Opened Last year Closed 11 months ago

"Safe Mode" is a misnomer

Categories

(Toolkit :: Startup and Profile System, defect, P1, minor)

59 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: erwinm, Assigned: Matthias)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180323154952

Steps to reproduce:

I am strobe-sensitive, and have to use a number of animation-blocking tools to use the web.

Standard advice when encountering problems, or debugging, is to restart Firefox in safe mode.


Actual results:

Since this disables add-ons, it disables a variety of safety tools. It may not be safe, e.g. for strobe-sensitive users.


Expected results:

I think a better term, which describes what safe mode does, would be better. It wouldn't imply that it is safe for all users.
The entry under the Help menu is titled, "Restart with Add-ons Disabled…"

Attempting to start in Safe Mode pops up the following dialog box:

"Firefox Safe Mode
Safe Mode is a special mode of Firefox that can be used to troubleshoot issues.
Your add-ons and custom settings will be temporarily disabled.
You can also skip troubleshooting and try refreshing Firefox.
[Start in Safe Mode] [Refresh Firefox]"
Severity: normal → minor
Component: Untriaged → Startup and Profile System
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
I agree that using this mode may not be safe for all users. We could use a different name, for example Troubleshooting Mode or Add-ons Disabled Mode, but it may still not be clear to all users what the implications of having add-ons disabled may be. These may range, for example, from reduced accessibility to additional tracking and profiling.

Renaming this mode may prove a challenge because, as you mentioned, most of the documentation and support on the web still refers to this as "safe mode", and those articles and forum posts would be impossible to update, creating a higher barrier for those looking for this functionality. I'd also expect most people to still call this "safe mode" unofficially even after we renamed it, because this is the industry standard for this kind of troubleshooting mode.

Still, maybe can improve the message shown at startup to make the implications clearer. Michelle, do you see any way of doing that?
Flags: needinfo?(mheubusch)
you can change the second sentence of the dialog to: Your add-ons and custom settings will be temporarily disabled, and Firefox features may not perform as they currently do.
I take it this also disables about:config fixes, such as blocking animation there, and disables user css fixes, such as blocking the animated tab throbber?
(In reply to MarjaE from comment #4)
> I take it this also disables about:config fixes, such as blocking animation
> there, and disables user css fixes, such as blocking the animated tab
> throbber?

The about:config settings are preserved, I don't know about the user.css fixes but I guess they are too. The feature is intended to help with basic troubleshooting, so the more advanced modifications are kept.
Confirming the bug since we have a clear decision for an action in comment 3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: good-first-bug
Priority: -- → P3
(In reply to :Paolo Amadini from comment #5)
> The about:config settings are preserved, I don't know about the user.css
> fixes but I guess they are too.

They're not. Bug 333808.
Flags: needinfo?(mheubusch)
I saw a shorter dialogue in FF61, it still refers to "safe mode," and doesn't mention disabling user (safety) css.
Assignee: nobody → matthias
Status: NEW → ASSIGNED
Blocks: 1493190
To emphasize the possible negative consequences for users.
Comment on attachment 9011110 [details]
Bug 1461010 - changed second sentence of Safe Mode dialogue. r?paolo

:Paolo Amadini has approved the revision.
Attachment #9011110 - Flags: review+
Comment on attachment 9011110 [details]
Bug 1461010 - changed second sentence of Safe Mode dialogue. r?paolo

Francesco Lodolo [:flod] has approved the revision.
Attachment #9011110 - Flags: review+
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/467b056f0870
Changed second sentence of Safe Mode dialogue. r=paolo,flod
Priority: P3 → P1
https://hg.mozilla.org/mozilla-central/rev/467b056f0870
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Comment on attachment 9011110 [details]
Bug 1461010 - changed second sentence of Safe Mode dialogue. r?paolo

:Paolo Amadini has been removed from the revision.
Attachment #9011110 - Flags: review+
You need to log in before you can comment on or make changes to this bug.