Closed Bug 1461207 Opened 2 years ago Closed 2 years ago

Interrupt underline where text crosses it, to avoid striking through descenders

Categories

(Core :: Layout: Block and Inline, enhancement)

61 Branch
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1019448

People

(Reporter: tobias, Unassigned)

Details

(Keywords: parity-chrome)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180510160705

Steps to reproduce:

This is a feature currently available in Google Chrome, and which I would love to see in Firefox as well. To see what I mean, here's the exact page where I noticed how nicely Chrome handles this situation.

https://en.wikipedia.org/w/index.php?title=User_talk:Pomac30&oldid=841031519#Proposed_deletion_of_Kortney_Kane

Hovering your mouse over "Kortney Kane" will underline the text. Doing so in Chrome avoids underlining the "y", which would otherwise be partly striked through by the underline. Firefox currently just mindlessly ignores this typography detail.

Here's another page I had printed today with Chrome:

https://beej.us/guide/bgnet/html/single/bgnet.html

It's the table of contents that makes the difference obvious. Wherever text crosses the underline, the underline is interrupted to avoid having a negative impact on legibility. There might be languages (Arabic perhaps?) containing horizontal lines that look really bad when wrongly striked through.


Actual results:

 


Expected results:
Attached image firefox-bad.png
Bad example: Firefox
Attached image chrome-good.png
Good Example: Chrome
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Closed: 2 years ago
Component: Untriaged → Layout: Block and Inline
Keywords: parity-chrome
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Summary: Interrupt underline where text crosses it, to avoid striking through text → Interrupt underline where text crosses it, to avoid striking through descenders
Duplicate of bug: 1019448
You need to log in before you can comment on or make changes to this bug.