Closed Bug 146142 Opened 19 years ago Closed 18 years ago

[LDIF export] Missing objectclass and inconsistent attributes

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 157926

People

(Reporter: roland.felnhofer, Assigned: sspitzer)

Details

Here are some commends on the LDIF (Inport /) Export
format:

1) The attribute 'c' ('countryName') is used but the objectclass 'country' isn't.
So we use an attribute without it's objectclass.

2) In addition the following 3 attributes are used which are proprietary Mozilla
attributes without the 'mozilla' prefix. It is still possible that they are
defined by RFCs but I haven't found any reference. So I you feel I'm wrong
please  evaluate what I've said. 
To keep all Mozilla internal attributes consistent I would recommend the following:

workurl -> mozillaWorkUrl
homeurl -> mozillaHomeUrl
custom1 -> mozillaCustom1
custom2 -> mozillaCustom2
custom3 -> mozillaCustom3
custom4 -> mozillaCustom4

3) I'm well aware that we still use 'xmozillanickname' and
'xmozillausehtmlmail'. For consistency it would be nice if we could change them
to 'mozillaNickname' and 'mozillaUseHtmlMail'. But there change might have a
broader impact that point 1 and 2

I think that point 1) can be easily done and it's risk is extremely small. It's
only used in the LDIF import and export routine and nowhere else.

Item 2 might have a little broader impact on existing code, depending if we also
want to update the LDAP part to support that newly named attributes there. To do
so I would highly appreciate but even to see a more homogeneous format in the
LDIF files I would see as a step forward in better ( and more consistent) LDAP
support within Mozilla

Item 3 might even have a broader impact for people already using Mozilla's LDAP
integration. 

So what are you thinking about that?
Summary: Inconsistent LDIF export (missing objectclass and inconsistent attributes) → [LDIF export] Missing objectclass and inconsistent attributes
taking, and cc'ing dmose as we've been working on this.
Assignee: racham → sspitzer

*** This bug has been marked as a duplicate of 157926 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.