Pref to resume downloads on Mozilla startup

RESOLVED DUPLICATE of bug 18004

Status

enhancement
RESOLVED DUPLICATE of bug 18004
17 years ago
15 years ago

People

(Reporter: taller, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

It would be nice the possibility to continue downloading a file next time you
start mozilla, when lets say you stopped the download by hand or by crash.

Reproducible: Always
Steps to Reproduce:
1.Stop a download
2.Exit mozilla
3.Start mozilla

Actual Results:  No question if you want to continue when starting mozilla.
If you try to continue the download again appears a message similar to "Do you
want to overwritte it?"

Expected Results:  Window asking to continue previous stopped download in start.
Possibility to continue download if you try to download an existing file further
to overwrite

Updated

17 years ago
Severity: normal → enhancement
Summary: Continue download in start of mozilla possibility → [RFE] Continue download in start of mozilla possibility

Comment 1

17 years ago
Actually I think, the best description is, make the Download Manager like the
one of Opera :-)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: [RFE] Continue download in start of mozilla possibility → [RFE] Pref to resume downloads on Mozilla startup
*** Bug 174533 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → petersen
Summary: [RFE] Pref to resume downloads on Mozilla startup → Pref to resume downloads on Mozilla startup
With a download manager included this should be easy to do:
The dowload manager already saves the location of the saved file and the URL
If you now add remembering the tempfile name, you just have to check for all
unfinished downloads if the tempfile still exists.

Depending on that you can allow the user to redownload or resume the download of
any file.

P.S.: I jsut want to suggest this, as this should be a easy way to realize and
it's a major feature. While with normal resume (on the actual saved file) this
would be major new work.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 18004 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.