The bookmarks toolbar is displayed empty after creating a separator before its first bookmark

RESOLVED FIXED in Firefox 62

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: JuliaC, Assigned: mak)

Tracking

({regression})

Trunk
Firefox 62
Points:
---
Dependency tree / graph
Bug Flags:
in-qa-testsuite +
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 wontfix, firefox60 wontfix, firefox61 wontfix, firefox62 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

[Affected versions]:
- 62.0a1 (2018-05-14)
- 61.0b5 (20180514150347)
- 60.0 build2 (20180503143129)

[Affected platforms]:
- Mac OS X 10.10.5
- Windows 10 x64
- Ubuntu 16.04 x86

[Steps to reproduce]:
1. Launch Firefox
2. Enable the bookmarks toolbar 
3. Create a separator before the first bookmark/folder from the toolbar 
4. Disable the bookmarks toolbar 
5. Enable back the bookmarks toolbar

[Expected result]:
- All its items are properly displayed

[Actual result]:
- The bookmarks toolbar is displayed as being empty 

[Regression range]:
- Last good revision: acf2ccf34d753305b27487c55ca80ad37b61136a
- First bad revision: a0be5817a7214701ba799edef2dcda16d29195fc
- Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=acf2ccf34d753305b27487c55ca80ad37b61136a&tochange=a0be5817a7214701ba799edef2dcda16d29195fc
- it seems that bug 1392081 regressed this problem

[Additional notes]:
- the issue is reproducible till deleting/moving the separator from that particular position
(Assignee)

Updated

a year ago
Blocks: 1392081
Priority: -- → P1
(Assignee)

Updated

a year ago
Whiteboard: [fxsearch]
(Assignee)

Updated

a year ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8976493 [details]
Bug 1461685 - The bookmarks toolbar is empty if the first bookmark is a separator.

https://reviewboard.mozilla.org/r/244616/#review251422
Attachment #8976493 - Flags: review?(standard8) → review+

Comment 3

a year ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/b0dc0094001b
The bookmarks toolbar is empty if the first bookmark is a separator. r=standard8

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b0dc0094001b
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.