Closed Bug 1461796 Opened 3 years ago Closed 2 years ago

Context menu opens in wrong position in Responsive Design Mode

Categories

(DevTools :: Responsive Design Mode, defect, P3)

60 Branch
defect

Tracking

(firefox60 affected, firefox61 affected, firefox62 affected)

RESOLVED DUPLICATE of bug 1488991
Tracking Status
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected

People

(Reporter: joshas, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [dt-q])

Attachments

(1 file)

Attached image context-menu-offset.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180503143129

Steps to reproduce:

1. Enable Responsive Design Mode and open Developer Tools. Developer Tools should be docked on the right side of the window.
2. Right click on website to open context menu.


Actual results:

Context menu horizontal position is offset to the right, vertical position is correct in relation to mouse cursor.
See attached screenshot, where I tried right clicking on center of Firefox logo.
If Developer Tools are docked to bottom - no problems. Also, clicking on outside of website (on dark area) results in correct context menu position.
I can confirm that this issue occurs only on Windows (7 and 10). Unable to reproduce it on Ubuntu.


Expected results:

Context menu should open right on the spot I have clicked.
Hi Joshas,

Managed to reproduce on Firefox Release 60.0, Firefox Beta 61.0b5 and latest Nightly 62.0a1(2018-05-17) – Windows 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.12.

However, after updating to the latest Firefox Release 60.0.1. I can no longer reproduce the issue on Windows 10 and Ubuntu. Note that on Mac it is still reproducible as described in the report.
Joshas, can you please also retest the issue on the latest Firefox Release 60.0.1. and report back the result?

Thank you.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Responsive Design Mode
Ever confirmed: true
Flags: needinfo?(joshas)
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Firefox 60.0.1 (64-bit) on Windows 7 - issue still exists, but after switching device (using Responsive Design Mode dropdown) popup menu works correctly, appears right under mouse cursor. Looks like that changing device causes some sort of refresh that fixes popup position issue.
If I hide Developer Tools from current state - context menu popup appears on left side of cursor position.
I hope it's enough information to track down this issue.
Flags: needinfo?(joshas)
Thanks for the report!  I can confirm that this still applies in Nightly 62.
Priority: -- → P3
Product: Firefox → DevTools
See Also: → 1488991
Blocks: rdm-ux

Issue still applies, even with DevTools closed. This happens to me whenever touch simulation is enabled and the viewport is fairly tall.

Summary: Context menu opens in wrong position when Developer Tools panel is docked on side → Context menu opens in wrong position when Developer Tools panel
Summary: Context menu opens in wrong position when Developer Tools panel → Context menu opens in wrong position on OS X
See Also: → 1404081

Issue still exists on Windows 7 (64-bit) Firefox 66.0 (64-bit). Developer Tools must be open to trigger incorrect positioning of context menu, while Responsive Design Mode is active.

Summary: Context menu opens in wrong position on OS X → Context menu opens in wrong position in Responsive Design Mode
OS: macOS → All
Whiteboard: [dt-q]

I can't reproduce this problem anymore. It might have been fixed by bug 1488991 in Firefox 67.
Joshas: would you mind please re-testing with Firefox 67?

Flags: needinfo?(joshas)

Tested on Firefox 67.0b19 (Linux version) and the issue is fixed. Context menu now opens in correct position.

Flags: needinfo?(joshas)

Excellent, thank you for testing again Joshas, and for your patience!
I'm going to preemptively mark this as a duplicate of bug 1488991 then.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1488991
You need to log in before you can comment on or make changes to this bug.