Closed Bug 1461912 Opened 2 years ago Closed 2 years ago

"Accessible Information Unavailable" message is displayed after enabling Accessibility Features

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 verified, firefox62 verified)

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- verified
firefox62 --- verified

People

(Reporter: emilghitta, Assigned: yzen)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
Firefox 62.0a1 (BuildId:20180515220059).

[Affected platforms]:
Windows 10 64bit
macOS 10.12
Ubuntu 16.04 64bit

[Steps to reproduce]:
1. Launch Firefox.
2. Access the https://vk.com/ webpage.
3. Enable the Accessibility features.

[Expected result]:
Specific information related to the opened website is displayed.

[Actual result]:
"Accessible information Unavailable" is displayed under the "Properties" panel.

[Regression range]:
This seems to be a regression:

Last good revision: 7201982e0481cbc237a21756ef88827c4dcfb2c8
First bad revision: b3147109d3af0945ed9783d513b14ffe3d755df3

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7201982e0481cbc237a21756ef88827c4dcfb2c8&tochange=b3147109d3af0945ed9783d513b14ffe3d755df3

[Additional information]:
For further information regarding this issue please observe the attached screencast.
Please note that this issue may occur by simply following the up mentioned steps or, additionally, you may have to disable/enable the accessibility feature a couple of times for this issue to occur.
Hi Yura,

It seems that mozregression pointed out Bug 1441187 for causing this regression.

Can you please have a look?

Thanks!
Flags: needinfo?(yzenevich)
Attached patch 1461912 patchSplinter Review
Since as of bug 1441187 we now rely on stale state instead of busy to determine document readiness, we should not clear accessible actors cache on busy event, as it is done when accessible actor for document is created.
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Flags: needinfo?(yzenevich)
Attachment #8977074 - Flags: review?(pbrosset)
Attachment #8977074 - Flags: review?(pbrosset) → review+
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ba4ce98ebac5
do not clear accessible actors cache when document becomes non-busy. r=pbro
Comment on attachment 8977074 [details] [diff] [review]
1461912 patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1441187
[User impact if declined]: This along with bug 1441187 are high priority bugs for a11y panel devtool.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: STR are in the description.
[List of other uplifts needed for the feature/fix]: depends on bug 1441187
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is a small change that makes the panel loading much more reliable.
[String changes made/needed]: None
Attachment #8977074 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/ba4ce98ebac5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Comment on attachment 8977074 [details] [diff] [review]
1461912 patch

Improvements for the a11y inspector. Approved for 61.0b8.
Attachment #8977074 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This issue is verified fixed using Firefox 62.0a1 (BuildId:20180523221148) and Firefox 61.0b8 (BuildId:20180524181234) on Windows 10 64bit, macOS 10.13.4 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.