Crash in mozalloc_abort | abort | libdbus-1.so.3.19.4@0x36203 | Firefox crashes on start up, suspect non-Latin profile name

RESOLVED FIXED in Firefox -esr60

Status

defect
RESOLVED FIXED
Last year
2 months ago

People

(Reporter: l.dobrev, Assigned: stransky)

Tracking

({crash})

60 Branch
mozilla62
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 fixed, firefox60 wontfix, firefox61 fixed, firefox62 fixed)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

Last year
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180517114003

Steps to reproduce:

Xubuntu 18.04, Firefox 60.0 and 60.0.1
1. Create profile with Cyrillic characters in the name, ex: Кирилица
2. Start Firefox with that profile: firefox -P "Кирилица"
+ same error if the default profile has non-Latin name and run default: firefox


Actual results:

Firefox crashes, shows "Report Bug" window.
Running in console shows error message:

dbus[7313]: arguments to dbus_bus_request_name() were incorrect, assertion "_dbus_check_is_valid_bus_name (name)" failed in file ../../../dbus/dbus-bus.c line 1122.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
Redirecting call to abort() to mozalloc_abort

ExceptionHandler::GenerateDump cloned child 7368
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...



Expected results:

Firefox should start normally.
Reporter

Comment 1

Last year
Current work-around:
firefox --profile /path/to/profile/directory
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
20180516032328

(In reply to Lachezar Dobrev from comment #0)
> 2. Start Firefox with that profile: firefox -P "Кирилица"

Works for me. Setting platform to Linux.

> Firefox crashes, shows "Report Bug" window.

Do you mean the crash reporter? If so, please enter about:crashes into the address bar and paste the relevant report ID in a comment here. Otherwise, please try a build from mozilla.org, report the crash from it, then post the report ID here.
https://developer.mozilla.org/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report
Has STR: --- → yes
Component: Untriaged → Startup and Profile System
Keywords: crash
OS: Unspecified → Linux
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
Reporter

Comment 3

Last year
Is this it:
https://crash-stats.mozilla.com/report/index/dfc68faa-8c45-4579-93b2-22de50180518

OS = Linux, yes
I do not thing DBus is available on other platforms, right?
Thank you.

:stransky this looks like your bailiwick. Please have a look if you can.
Crash Signature: [@ mozalloc_abort | abort | libdbus-1.so.3.19.4@0x36203 ]
Component: Startup and Profile System → X-remote
Flags: needinfo?(stransky)
Product: Toolkit → Core
Summary: Firefox crashes on start up, suspect non-Latin profile name → Crash in mozalloc_abort | abort | libdbus-1.so.3.19.4@0x36203 | Firefox crashes on start up, suspect non-Latin profile name
Sure.
Assignee: nobody → stransky
Flags: needinfo?(stransky)
Assignee

Updated

Last year
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

Last year
mozreview-review
Comment on attachment 8976922 [details]
Bug 1462571 - Check dbus name by dbus_validate_bus_name() before use,

https://reviewboard.mozilla.org/r/245084/#review251038
Attachment #8976922 - Flags: review?(jhorak) → review+

Comment 8

Last year
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/09a2a68cfc77
Check dbus name by dbus_validate_bus_name() before use, r=jhorak

Comment 9

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/09a2a68cfc77
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Please request Beta and ESR60 approval on this patch when you're comfortable doing so.
Flags: needinfo?(l.dobrev)
Flags: needinfo?(l.dobrev) → needinfo?(stransky)
Comment on attachment 8976922 [details]
Bug 1462571 - Check dbus name by dbus_validate_bus_name() before use,

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: Firefox crashes at start up when Cyrillic characters is used at profile name.
Fix Landed on Version: 62.0
Risk to taking this patch (and alternatives if risky): low, baked on nightly and it's one time check at browser start up.
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Flags: needinfo?(stransky)
Attachment #8976922 - Flags: approval-mozilla-esr60?
Comment on attachment 8976922 [details]
Bug 1462571 - Check dbus name by dbus_validate_bus_name() before use,

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1360566
[User impact if declined]: Firefox crashes at start up when Cyrillic characters is used at profile name.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: Low risk as it's one time check at browser start up.
[String changes made/needed]: none
Attachment #8976922 - Flags: approval-mozilla-beta?
Comment on attachment 8976922 [details]
Bug 1462571 - Check dbus name by dbus_validate_bus_name() before use,

Fix for possible startup crash on some Linux systems. Approved for 61.0b9 and ESR 60.1.
Attachment #8976922 - Flags: approval-mozilla-esr60?
Attachment #8976922 - Flags: approval-mozilla-esr60+
Attachment #8976922 - Flags: approval-mozilla-beta?
Attachment #8976922 - Flags: approval-mozilla-beta+
Reporter

Comment 16

Last year
I tried Beta and Nightly channel releases:

Pass on 62.0a1 (2018-05-27) (64-bit).

Fail on 61.0b8 (64-bit):

https://crash-stats.mozilla.com/report/index/10f93217-45cc-4e25-85d0-29db70180528

dbus[18483]: arguments to dbus_bus_request_name() were incorrect, assertion "_dbus_check_is_valid_bus_name (name)" failed in file ../../../dbus/dbus-bus.c line 1122.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
Redirecting call to abort() to mozalloc_abort

ExceptionHandler::GenerateDump cloned child 18570
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Per comment 13, the fix will be in b9, not b8.
FYI, this spawned bug #1472611
Depends on: 1472611

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.