Closed Bug 1462857 Opened 4 years ago Closed 4 years ago

A visual glitch appears on a pop-up panel by scrolling when using Hatena Bookmark Extension with Firefox 60 / 61.

Categories

(WebExtensions :: General, defect)

61 Branch
Unspecified
Windows
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1420865

People

(Reporter: rockridge07, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180518100150

Steps to reproduce:

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

1. Install Hatena Bookmark Extension. The icon is placed on the toolbar.
2. Sign in Hatena Account.
3. Open a web page.
4. Click the extension's icon and click "ブックマークする".
5. Fill in the input field. When you have dozes of words, scrolling occurs.


Actual results:

A visual glitch of black bar appears for some time. When you scroll the panel, the glitch re-appears.

Your input can not be reflected on the panel while the glich apears.

Workaround: extensions.webextensions.remote set to be false.


Expected results:

No visual glitch appears.

I didn't see this problem with Firefox 59 and I don't see it with the current Nightly.
It's a regression.

I've no idea about what fixed this problem on the Trunk, but I think it's worth uplifting at least for Beta channel.
Has STR: --- → yes
OS: Unspecified → Windows
(In reply to Alice0775 White from comment #1)
> fixed range:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=fb2b32cae6e816e4f3da342203e8ea31bb840c13&tochange=eb03
> 6f55167d9369d12c131ae019a1a633986009
> 
> Fixed by Bug 1366808 in nightly62

This is rather surprising... Is this 100% reproducible?
(In reply to Stephen A Pohl [:spohl] from comment #2)
> (In reply to Alice0775 White from comment #1)
> > fixed range:
> > https://hg.mozilla.org/integration/mozilla-inbound/
> > pushloghtml?fromchange=fb2b32cae6e816e4f3da342203e8ea31bb840c13&tochange=eb03
> > 6f55167d9369d12c131ae019a1a633986009
> > 
> > Fixed by Bug 1366808 in nightly62
> 
> This is rather surprising... Is this 100% reproducible?


OOps, that my bad.

Fixed range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=eb036f55167d9369d12c131ae019a1a633986009&tochange=0a1ffd5411da28c2f550620372fe421b4e8e165d

Fixed by 0a1ffd5411da	Ryan Hunt — Bug 1420865 - Don't check for CONTENT_MAY_CHANGE_TRANSFORM across layer trees. r=mstange



Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a4fb78381ea0fe9fddd36a8ea7b74a63062a1bf3&tochange=66ef885f0b66cb680a3f0734bfbfd8fd385fa104

Regressed by: 66ef885f0b66	Markus Stange — Bug 1400259 - Add will-change:transform to the panel in order to work around a compositor bug. r=mconley
Blocks: 1400259
Component: IPC → WebExtensions: General
Depends on: 1420865
No longer depends on: 1366808
Product: Core → Toolkit
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1420865
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.