Closed Bug 1462993 Opened Last year Closed Last year

PerformanceObserver.observe should not throw if the list is empty

Categories

(Core :: DOM: Core & HTML, defect, P2)

58 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1403027

People

(Reporter: baku, Assigned: baku)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

https://w3c.github.io/performance-timeline/#dom-performanceobserver-observe
"If the resulting entry types sequence is an empty sequence, abort these steps."
Attachment #8979110 - Flags: review?(valentin.gosu)
Comment on attachment 8979110 [details] [diff] [review]
performance7.patch

Review of attachment 8979110 [details] [diff] [review]:
-----------------------------------------------------------------

Make sure to use add the reasoning and link to the commit message description.
Attachment #8979110 - Flags: review?(valentin.gosu) → review+
Blocks: 1462606
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/591cbed375cd
PerformanceObserver.observe should not throw if the list is empty, r=valentin
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5486694a9bc9
Fixing a failure related to PerformanceObserver in longtask-tojson.html, r=me
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/53a1f773dfd0
Fixing a failure related to PerformanceObserver in longtask-tojson.html, r=me CLOSED TREE
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d1d7f3f32600
Backed out 3 changesets wpt failures on nav2_test_attributes_exist.html. CLOSED TREE
Depends on: 1464135
Flags: needinfo?(amarchesini)
Priority: -- → P2
Note that I was working on this in bug 1403027, which I'm presently trying to land (sorry, I just found this bug).
baku, it looks like bug 1403027 has landed. It looks like this one be closed a duplicate?
Flags: needinfo?(amarchesini)
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1403027
Removing DDN, as this is a Dupe
Keywords: dev-doc-needed
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.