Closed Bug 1463627 Opened Last year Closed Last year

[wpt-sync] Sync PR 11113 - FormData: Strings from form controls should be converted to USVStrings

Categories

(Core :: DOM: Core & HTML, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: wptsync, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 11113 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/w3c/web-platform-tests/pull/11113
Details from upstream follow.

Kent Tamura <tkent@chromium.org> wrote:
>  FormData: Strings from form controls should be converted to USVStrings
>  
>  This CL fixes a regression by crrev.com/560505.
>  
>  Before r560505 such strings were converted to USVStrings implicitly
>  because FromData::Entry stored encoded CStrings, and text encoders
>  replace unpaired surrogates with U+FFFD. Since r560505 we don't apply
>  text encoding in FormData::Entry, and need to convert strings to
>  USVStrings explicitly.
>  
>  This CL also adds DCHECKs to FormData::Entry constructors.
>  
>  Bug: 845744
>  Change-Id: I9893848f4e32fbe3c0c7a8f787584fbbb8ba8e87
>  
>  Reviewed-on: https://chromium-review.googlesource.com/1067560
>  WPT-Export-Revision: 442a3f5c1131d2b0474ed658f7635e3d91a937e1
Component: web-platform-tests → DOM
Product: Testing → Core
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9ef474e6cce0
[wpt PR 11113] - FormData: Strings from form controls should be converted to USVStrings, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/0b9d728e905d
[wpt PR 11113] - Update wpt metadata, a=testonly
https://hg.mozilla.org/mozilla-central/rev/9ef474e6cce0
https://hg.mozilla.org/mozilla-central/rev/0b9d728e905d
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.