Closed Bug 1463863 Opened 2 years ago Closed 2 years ago

Intermittent dom/file/tests/test_fileapi_slice_realFile_2.html | application crashed [@ MOZ_CrashOOL] after TEST-UNEXPECTED-FAIL | dom/file/tests/test_fileapi_slice_realFile_2.html | application terminated with exit code 1

Categories

(Core :: DOM: File, defect, P5, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1464090

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: crash, intermittent-failure)

Crash Data

Filed by: toros [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=179874762&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/GAv86M66ReGv5518zBeAyQ/runs/0/artifacts/public/logs/live_backing.log

18:33:36     INFO -  3469 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | [XHR] no error in test XMLHttpRequest load of fileFile slice(50, -88154)
18:33:36     INFO -  3470 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | [XHR] Length of result in test XMLHttpRequest load of fileFile slice(50, -88154)
18:33:36     INFO -  3471 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | [XHR] Content of result in test XMLHttpRequest load of fileFile slice(50, -88154)
18:33:36     INFO -  3472 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | [XHR] lengthComputable in test XMLHttpRequest load of fileFile slice(50, -88154)
18:33:36     INFO -  3473 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | [XHR] Loaded length in test XMLHttpRequest load of fileFile slice(50, -88154)
18:33:36     INFO -  3474 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | [XHR] Total length in test XMLHttpRequest load of fileFile slice(50, -88154)
18:33:36     INFO -  3475 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Correct number of items
18:33:36     INFO -  3476 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Correct name (A)
18:33:36     INFO -  3477 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Wrong number of headers (A)
18:33:36     INFO -  3478 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Length of correct value
18:33:36     INFO -  3479 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Content of correct value
18:33:36     INFO -  3480 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Correct name (B)
18:33:36     INFO -  3481 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Correct content type (B)
18:33:36     INFO -  3482 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Wrong number of headers (B)
18:33:36     INFO -  3483 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Length of correct value
18:33:36     INFO -  3484 INFO TEST-PASS | dom/file/tests/test_fileapi_slice_realFile_2.html | Content of correct value
18:33:36     INFO -  Buffered messages finished
18:33:36    ERROR -  3485 ERROR TEST-UNEXPECTED-FAIL | dom/file/tests/test_fileapi_slice_realFile_2.html | application terminated with exit code 1
18:33:36     INFO -  runtests.py | Application ran for: 0:00:32.989000
18:33:36     INFO -  zombiecheck | Reading PID log: c:\users\task_1527098818\appdata\local\temp\tmpf1ckx7pidlog
18:33:36     INFO -  ==> process 5724 launched child process 3180 ("Z:\task_1527098818\build\application\firefox\firefox.exe" -contentproc --channel="5724.0.1430157717\1372811703" -childID 1 -isForBrowser -prefsHandle 2080 -prefsLen 16342 -schedulerPrefs 0001,2 -parentBuildID 20180523170900 -greomni "Z:\task_1527098818\build\application\firefox\omni.ja" -appomni "Z:\task_1527098818\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1527098818\build\application\firefox\browser" - 5724 "\\.\pipe\gecko-crash-server-pipe.5724" 2124 tab)
18:33:36     INFO -  ==> process 5724 launched child process 4056 ("Z:\task_1527098818\build\application\firefox\firefox.exe" -contentproc --channel="5724.6.898650876\761308992" -childID 2 -isForBrowser -prefsHandle 2464 -prefsLen 16342 -schedulerPrefs 0001,2 -parentBuildID 20180523170900 -greomni "Z:\task_1527098818\build\application\firefox\omni.ja" -appomni "Z:\task_1527098818\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1527098818\build\application\firefox\browser" - 5724 "\\.\pipe\gecko-crash-server-pipe.5724" 2472 tab)
18:33:36     INFO -  ==> process 5724 launched child process 2980 ("Z:\task_1527098818\build\application\firefox\firefox.exe" -contentproc --channel="5724.12.1824571832\1518848955" -childID 3 -isForBrowser -prefsHandle 2396 -prefsLen 17652 -schedulerPrefs 0001,2 -parentBuildID 20180523170900 -greomni "Z:\task_1527098818\build\application\firefox\omni.ja" -appomni "Z:\task_1527098818\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1527098818\build\application\firefox\browser" - 5724 "\\.\pipe\gecko-crash-server-pipe.5724" 2000 tab)
18:33:36     INFO -  zombiecheck | Checking for orphan process with PID: 4056
18:33:36     INFO -  zombiecheck | Checking for orphan process with PID: 2980
18:33:36     INFO -  zombiecheck | Checking for orphan process with PID: 3180
18:33:36     INFO -  mozcrash Copy/paste: Z:\task_1527098818\build\win32-minidump_stackwalk.exe c:\users\task_1527098818\appdata\local\temp\tmpgsd5xg.mozrunner\minidumps\2005e60f-db54-407c-a877-0cb8b5ebf0c5.dmp Z:\task_1527098818\build\symbols
18:33:49     INFO -  mozcrash Saved minidump as Z:\task_1527098818\build\blobber_upload_dir\2005e60f-db54-407c-a877-0cb8b5ebf0c5.dmp
18:33:49     INFO -  mozcrash Saved app info as Z:\task_1527098818\build\blobber_upload_dir\2005e60f-db54-407c-a877-0cb8b5ebf0c5.extra
18:33:49  WARNING -  PROCESS-CRASH | dom/file/tests/test_fileapi_slice_realFile_2.html | application crashed [@ MOZ_CrashOOL]
18:33:49     INFO -  Crash dump filename: c:\users\task_1527098818\appdata\local\temp\tmpgsd5xg.mozrunner\minidumps\2005e60f-db54-407c-a877-0cb8b5ebf0c5.dmp
18:33:49     INFO -  Operating system: Windows NT
18:33:49     INFO -                    10.0.15063
18:33:49     INFO -  CPU: amd64
18:33:49     INFO -       family 6 model 63 stepping 2
18:33:49     INFO -       8 CPUs
18:33:49     INFO -  GPU: UNKNOWN
18:33:49     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
18:33:49     INFO -  Crash address: 0x7ffd1d822214
18:33:49     INFO -  Process uptime: 32 seconds
18:33:49     INFO -  Thread 63 (crashed)
18:33:49     INFO -   0  mozglue.dll!MOZ_CrashOOL [Assertions.cpp:aa92307e79b5e6bee12442ffe04111de647d096f : 33 + 0x0]
18:33:49     INFO -      rax = 0x0000000000000000   rdx = 0x0000000000000000
18:33:49     INFO -      rcx = 0x00000000ffffffff   rbx = 0x00007ffd0cbdb048
18:33:49     INFO -      rsi = 0x0000000000000001   rdi = 0x000000000000002e
18:33:49     INFO -      rbp = 0x00000075bb9ff169   rsp = 0x00000075bb9fefc0
18:33:49     INFO -       r8 = 0x00000075bb9fd898    r9 = 0x0000000000000000
18:33:49     INFO -      r10 = 0x0000000000000000   r11 = 0x00000075bb9fee40
18:33:49     INFO -      r12 = 0x0000000000000000   r13 = 0x0000000000000000
18:33:49     INFO -      r14 = 0x0000017fe3bf6f00   r15 = 0x0000017fed9352b0
18:33:49     INFO -      rip = 0x00007ffd1d822214
18:33:49     INFO -      Found by: given as instruction pointer in context
18:33:49     INFO -   1  xul.dll!nsAutoOwningThread::AssertCurrentThreadOwnsMe(char const *) [nsISupportsImpl.cpp:aa92307e79b5e6bee12442ffe04111de647d096f : 46 + 0x15]
18:33:49     INFO -      rbx = 0x00007ffd0cbdb048   rbp = 0x00000075bb9ff169
18:33:49     INFO -      rsp = 0x00000075bb9feff0   r12 = 0x0000000000000000
18:33:49     INFO -      r13 = 0x0000000000000000   r14 = 0x0000017fe3bf6f00
18:33:49     INFO -      r15 = 0x0000017fed9352b0   rip = 0x00007ffd07a4c54f
18:33:49     INFO -      Found by: call frame info
18:33:49     INFO -   2  xul.dll!mozilla::net::HttpChannelParent::Release() [HttpChannelParent.cpp:aa92307e79b5e6bee12442ffe04111de647d096f : 285 + 0x23]
18:33:49     INFO -      rbx = 0x00007ffd0cbdb048   rbp = 0x00000075bb9ff169
18:33:49     INFO -      rsp = 0x00000075bb9ff020   r12 = 0x0000000000000000
18:33:49     INFO -      r13 = 0x0000000000000000   r14 = 0x0000017fe3bf6f00
18:33:49     INFO -      r15 = 0x0000017fed9352b0   rip = 0x00007ffd07f1a1bf
18:33:49     INFO -      Found by: call frame info
18:33:49     INFO -   3  xul.dll!void std::_Func_impl_no_alloc<<lambda_3d72daabeec4e540a55137ada0758901>,void,__int64>::_Delete_this(bool) [functional:aa92307e79b5e6bee12442ffe04111de647d096f : 448 + 0x1d]
18:33:49     INFO -      rbx = 0x00007ffd0cbdb048   rbp = 0x00000075bb9ff169
18:33:49     INFO -      rsp = 0x00000075bb9ff050   r12 = 0x0000000000000000
18:33:49     INFO -      r13 = 0x0000000000000000   r14 = 0x0000017fe3bf6f00
18:33:49     INFO -      r15 = 0x0000017fed9352b0   rip = 0x00007ffd07f2ad11
18:33:49     INFO -      Found by: call frame info
18:33:49     INFO -   4  xul.dll!mozilla::`anonymous namespace'::AvailableEvent::`scalar deleting destructor'(unsigned int) + 0x52
18:33:49     INFO -      rbx = 0x00007ffd0cbdb048   rbp = 0x00000075bb9ff169
18:33:49     INFO -      rsp = 0x00000075bb9ff080   r12 = 0x0000000000000000
18:33:49     INFO -      r13 = 0x0000000000000000   r14 = 0x0000017fe3bf6f00
18:33:49     INFO -      r15 = 0x0000017fed9352b0   rip = 0x00007ffd07a938de
18:33:49     INFO -      Found by: call frame info
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: RunWatchdogShutdownhang
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Over the last 7 days there are 31 failures on this bug. These happen on android-4-3-armv7-api16, linux64, osx-10-10, windows10-64, windows7-32

Here is the most recent log example: https://treeherder.mozilla.org/logviewer.html#?job_id=181241157&repo=mozilla-central&lineNumber=8288

23:24:53    ERROR -  3430 ERROR TEST-UNEXPECTED-FAIL | dom/file/tests/test_fileapi_slice_realFile_2.html | application terminated with exit code 1
23:24:53     INFO -  runtests.py | Application ran for: 0:00:34.052000
23:24:53     INFO -  zombiecheck | Reading PID log: c:\users\task_1527807820\appdata\local\temp\tmptgljb2pidlog
23:24:53     INFO -  ==> process 5412 launched child process 3140 ("Z:\task_1527807820\build\application\firefox\firefox.exe" -contentproc --channel="5412.0.1865195004\1704720847" -childID 1 -isForBrowser -prefsHandle 2036 -prefsLen 16262 -schedulerPrefs 0001,2 -parentBuildID 20180531215041 -greomni "Z:\task_1527807820\build\application\firefox\omni.ja" -appomni "Z:\task_1527807820\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1527807820\build\application\firefox\browser" - 5412 "\\.\pipe\gecko-crash-server-pipe.5412" 2080 tab)
23:24:53     INFO -  ==> process 5412 launched child process 6596 ("Z:\task_1527807820\build\application\firefox\firefox.exe" -contentproc --channel="5412.6.1093130128\1875884637" -childID 2 -isForBrowser -prefsHandle 2456 -prefsLen 16262 -schedulerPrefs 0001,2 -parentBuildID 20180531215041 -greomni "Z:\task_1527807820\build\application\firefox\omni.ja" -appomni "Z:\task_1527807820\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1527807820\build\application\firefox\browser" - 5412 "\\.\pipe\gecko-crash-server-pipe.5412" 1392 tab)
23:24:53     INFO -  ==> process 5412 launched child process 5860 ("Z:\task_1527807820\build\application\firefox\firefox.exe" -contentproc --channel="5412.12.10026896\289191387" -childID 3 -isForBrowser -prefsHandle 2808 -prefsLen 17572 -schedulerPrefs 0001,2 -parentBuildID 20180531215041 -greomni "Z:\task_1527807820\build\application\firefox\omni.ja" -appomni "Z:\task_1527807820\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1527807820\build\application\firefox\browser" - 5412 "\\.\pipe\gecko-crash-server-pipe.5412" 2812 tab)
23:24:53     INFO -  zombiecheck | Checking for orphan process with PID: 6596
23:24:53     INFO -  zombiecheck | Checking for orphan process with PID: 3140
23:24:53     INFO -  zombiecheck | Checking for orphan process with PID: 5860
23:24:53     INFO -  mozcrash Copy/paste: Z:\task_1527807820\build\win32-minidump_stackwalk.exe c:\users\task_1527807820\appdata\local\temp\tmph7rs2l.mozrunner\minidumps\271a78b9-2367-433e-aeb9-f964b7ef61bc.dmp Z:\task_1527807820\build\symbols
23:25:03     INFO -  mozcrash Saved minidump as Z:\task_1527807820\build\blobber_upload_dir\271a78b9-2367-433e-aeb9-f964b7ef61bc.dmp
23:25:03     INFO -  mozcrash Saved app info as Z:\task_1527807820\build\blobber_upload_dir\271a78b9-2367-433e-aeb9-f964b7ef61bc.extra
23:25:03  WARNING -  PROCESS-CRASH | dom/file/tests/test_fileapi_slice_realFile_2.html | application crashed [@ MOZ_CrashOOL]
Flags: needinfo?(amarchesini)
This crash has been fixed by 1464090.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1464090
You need to log in before you can comment on or make changes to this bug.