Closed Bug 1463985 Opened 2 years ago Closed 2 years ago

Rename EditAction to MicroEditAction, SubEditAction, EditSubAction or something

Categories

(Core :: DOM: Editor, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

(Blocks 1 open bug)

Details

Attachments

(27 files)

59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
59 bytes, text/x-review-board-request
m_kato
: review+
Details
I'd like to use EditAction to indicate top-level edit action which can be mapped to an input type value <https://www.w3.org/TR/input-events-2/#dfn-inputtype-values>.

However, we already have EditAction which is for smaller edit task. E.g., when editor receives insertText and there is a selected text, first, HTMLEditRules::WillInsertText() calls HTMLEditor::DeleteSelectionAsAction() to delete selected content, then, it sets AutoRules to deleteSelection and finally, inserts text with insertText. So, per an editing operation or editing command, EditAction may be used two or more.

Therefore, current EditAction should be renamed to something indicate smaller edit action than top level edit action. Perhaps, EditSubAction is better name:
https://en.wiktionary.org/wiki/subaction

HTML 5 has terms microtask. So, MicroEditAction or EditMicroAction might be good name, however, it sounds like each DOM tree change.

Makoto-san, if you have some ideas, let me know.
Priority: -- → P3
Comment on attachment 8981310 [details]
Bug 1463985 - part 1: Rename EditAction to EditSubAction and related stuff

https://reviewboard.mozilla.org/r/247422/#review253900

::: editor/libeditor/TextEditRules.h:517
(Diff revision 1)
>   * An object to encapsulate any additional info needed to be passed
>   * to rules system by the editor.
>   * TODO: This class (almost struct, though) is ugly and its size isn't
>   *       optimized.  Should be refined later.
>   */
> -class RulesInfo final
> +class EditSubActionInfo final

Could you add MOZ_STACK_CLASS attribute?
Attachment #8981310 - Flags: review?(m_kato) → review+
Comment on attachment 8981311 [details]
Bug 1463985 - part 2: Rename EditSubAction::none to EditSubAction::eNone

https://reviewboard.mozilla.org/r/247424/#review253902
Attachment #8981311 - Flags: review?(m_kato) → review+
Comment on attachment 8981312 [details]
Bug 1463985 - part 3: Rename EditSubAction::undo and EditSubAction::redo to EditSubAction::eUndo and EditSubAction::eRedo

https://reviewboard.mozilla.org/r/247426/#review253904
Attachment #8981312 - Flags: review?(m_kato) → review+
Comment on attachment 8981313 [details]
Bug 1463985 - part 4: Rename EditSubAction::insertNode and EditSubAction::createNode to EditSubAction::eInsertNode and EditSubAction::eCreateNode

https://reviewboard.mozilla.org/r/247428/#review253908
Attachment #8981313 - Flags: review?(m_kato) → review+
Comment on attachment 8981314 [details]
Bug 1463985 - part 5: Rename EditSubAction::deleteNode to EditSubAction::eDeleteNode

https://reviewboard.mozilla.org/r/247430/#review253910
Attachment #8981314 - Flags: review?(m_kato) → review+
Comment on attachment 8981315 [details]
Bug 1463985 - part 6: Rename EditSubAction::splitNode and EditSubAction::joinNode to EditSubAction::eSplitNode and EditSubAction::eJoinNodes

https://reviewboard.mozilla.org/r/247432/#review253922
Attachment #8981315 - Flags: review?(m_kato) → review+
Comment on attachment 8981316 [details]
Bug 1463985 - part 7: Rename EditSubAction::eDeleteText to EditSubAction::deleteText

https://reviewboard.mozilla.org/r/247434/#review253936
Attachment #8981316 - Flags: review?(m_kato) → review+
Comment on attachment 8981317 [details]
Bug 1463985 - part 8: Rename EditSubAction::insertText to EditSubAction::eInsertText

https://reviewboard.mozilla.org/r/247436/#review253942
Attachment #8981317 - Flags: review?(m_kato) → review+
Comment on attachment 8981318 [details]
Bug 1463985 - part 9: Rename EditSubAction::insertIMEText to EditSubAction::eInsertTextComingFromIME

https://reviewboard.mozilla.org/r/247438/#review253944
Attachment #8981318 - Flags: review?(m_kato) → review+
Comment on attachment 8981319 [details]
Bug 1463985 - part 10: Rename EditSubAction::deleteSelection to EditSubAction::eDeleteSelectedContent

https://reviewboard.mozilla.org/r/247440/#review253950
Attachment #8981319 - Flags: review?(m_kato) → review+
Comment on attachment 8981320 [details]
Bug 1463985 - part 11: Rename EditSubAction::setTextProperty and EditSubAction::removeTextProperty to EditSubAction::eSetTextProperty and EditSubAction::eRemoveTextProperty

https://reviewboard.mozilla.org/r/247442/#review253956
Attachment #8981320 - Flags: review?(m_kato) → review+
Comment on attachment 8981321 [details]
Bug 1463985 - part 12: Rename EditSubAction::outputText to EditSubAction::eComputeTextToOutput

https://reviewboard.mozilla.org/r/247444/#review253958
Attachment #8981321 - Flags: review?(m_kato) → review+
Comment on attachment 8981322 [details]
Bug 1463985 - part 13: Rename EditSubAction::setText to EditSubAction::eSetText

https://reviewboard.mozilla.org/r/247446/#review254272
Attachment #8981322 - Flags: review?(m_kato) → review+
Comment on attachment 8981323 [details]
Bug 1463985 - part 14: Rename EditSubAction::insertBreak to EditSubAction::eInsertParagraphSeparator

https://reviewboard.mozilla.org/r/247448/#review254274
Attachment #8981323 - Flags: review?(m_kato) → review+
Comment on attachment 8981324 [details]
Bug 1463985 - part 15: Rename EditSubAction::makeList to EditSubAction::eCreateOrChangeList

https://reviewboard.mozilla.org/r/247450/#review254292
Attachment #8981324 - Flags: review?(m_kato) → review+
Comment on attachment 8981325 [details]
Bug 1463985 - part 16: Rename EditSubAction::indent and EditSubAction::outdent to EditSubAction::eIndent and EditSubAction::eOutdent

https://reviewboard.mozilla.org/r/247452/#review254294
Attachment #8981325 - Flags: review?(m_kato) → review+
Comment on attachment 8981326 [details]
Bug 1463985 - part 17: Rename EditSubAction::align to EditSubAction::eSetOrClearAlignment

https://reviewboard.mozilla.org/r/247454/#review254298
Attachment #8981326 - Flags: review?(m_kato) → review+
Comment on attachment 8981327 [details]
Bug 1463985 - part 18: Rename EditSubAction::makeBasicBlock to EditSubAction::eCreateOrRemoveBlock

https://reviewboard.mozilla.org/r/247456/#review254300
Attachment #8981327 - Flags: review?(m_kato) → review+
Comment on attachment 8981328 [details]
Bug 1463985 - part 19: Rename EditSubAction::removeList to EditSubAction::eRemoveList

https://reviewboard.mozilla.org/r/247458/#review254302
Attachment #8981328 - Flags: review?(m_kato) → review+
Comment on attachment 8981329 [details]
Bug 1463985 - part 20: Rename EditSubAction::makeDefListItem to EditSubAction::eCreateOrChangeDefinitionList

https://reviewboard.mozilla.org/r/247460/#review254304
Attachment #8981329 - Flags: review?(m_kato) → review+
Comment on attachment 8981330 [details]
Bug 1463985 - part 21: Rename EditSubAction::insertElement to EditSubAction::eInsertElement

https://reviewboard.mozilla.org/r/247462/#review254306
Attachment #8981330 - Flags: review?(m_kato) → review+
Comment on attachment 8981331 [details]
Bug 1463985 - part 22: Rename EditSubAction::insertQuotation to EditSubAction::eInsertQuotation

https://reviewboard.mozilla.org/r/247464/#review254308
Attachment #8981331 - Flags: review?(m_kato) → review+
Comment on attachment 8981332 [details]
Bug 1463985 - part 23: Rename EditSubAction::htmlPaste and EditSubAction::loadHTML to EditSubAction::ePasteHTMLContent and EditSubAction::eInsertHTMLSource

https://reviewboard.mozilla.org/r/247466/#review254312
Attachment #8981332 - Flags: review?(m_kato) → review+
Comment on attachment 8981333 [details]
Bug 1463985 - part 24: Rename EditSubAction::resetTextProperties to EditSubAction::eRemoveAllTextProperties

https://reviewboard.mozilla.org/r/247468/#review254316
Attachment #8981333 - Flags: review?(m_kato) → review+
Comment on attachment 8981334 [details]
Bug 1463985 - part 25: Rename EditSubAction::setAbsolutePosition and EditSubAction::removeAbsolutePosition to EditSubAction::eSetPositionToAbsolute and EditSubAction::eSetPositionToStatic

https://reviewboard.mozilla.org/r/247470/#review254318

::: editor/libeditor/EditAction.h:112
(Diff revision 1)
>  
>    // eInsertHTMLSource indicates to create a document fragment from given HTML
>    // source and insert into the DOM tree.  So, this is similar to innerHTML.
>    eInsertHTMLSource,
>  
> -  setAbsolutePosition,
> +  // eSetPositionToAbsolute and eSetPositionToStatic indicates to set position

s/indicates/indicate/
Attachment #8981334 - Flags: review?(m_kato) → review+
Comment on attachment 8981335 [details]
Bug 1463985 - part 26: Rename EditSubAction::decreaseZIndex and EditSubAction::increaseZIndex to EditSubAction::eDecreaseZIndex and EditSubAction::eIncreaseZIndex

https://reviewboard.mozilla.org/r/247472/#review254320

::: editor/libeditor/EditAction.h:117
(Diff revision 1)
>    // eSetPositionToAbsolute and eSetPositionToStatic indicates to set position
>    // property to absolute or static.
>    eSetPositionToAbsolute,
>    eSetPositionToStatic,
>  
> -  decreaseZIndex,
> +  // eDecreaseZIndex and eIncreaseZIndex indicates to decrease and increase

nit: indicate
Attachment #8981335 - Flags: review?(m_kato) → review+
Comment on attachment 8981336 [details]
Bug 1463985 - part 27: Replace EditSubAction::ignore with EditSubAction::eReplaceHeadWithHTMLSource and EditSubAction::eCreateBogusNode

https://reviewboard.mozilla.org/r/247474/#review254322
Attachment #8981336 - Flags: review?(m_kato) → review+
Makoto-san:

Really thank you for taking a lot of your time!
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/1d39e0165b41
part 1: Rename EditAction to EditSubAction and related stuff r=m_kato
https://hg.mozilla.org/integration/autoland/rev/a653f964dbf8
part 2: Rename EditSubAction::none to EditSubAction::eNone r=m_kato
https://hg.mozilla.org/integration/autoland/rev/14054ff18010
part 3: Rename EditSubAction::undo and EditSubAction::redo to EditSubAction::eUndo and EditSubAction::eRedo r=m_kato
https://hg.mozilla.org/integration/autoland/rev/fba1566eb6a0
part 4: Rename EditSubAction::insertNode and EditSubAction::createNode to EditSubAction::eInsertNode and EditSubAction::eCreateNode r=m_kato
https://hg.mozilla.org/integration/autoland/rev/1e428fda3c71
part 5: Rename EditSubAction::deleteNode to EditSubAction::eDeleteNode r=m_kato
https://hg.mozilla.org/integration/autoland/rev/432c41a3f433
part 6: Rename EditSubAction::splitNode and EditSubAction::joinNode to EditSubAction::eSplitNode and EditSubAction::eJoinNodes r=m_kato
https://hg.mozilla.org/integration/autoland/rev/e1135fe082bc
part 7: Rename EditSubAction::eDeleteText to EditSubAction::deleteText r=m_kato
https://hg.mozilla.org/integration/autoland/rev/666cdc7ef8e2
part 8: Rename EditSubAction::insertText to EditSubAction::eInsertText r=m_kato
https://hg.mozilla.org/integration/autoland/rev/a343a1752684
part 9: Rename EditSubAction::insertIMEText to EditSubAction::eInsertTextComingFromIME r=m_kato
https://hg.mozilla.org/integration/autoland/rev/d2d0b0d3b43b
part 10: Rename EditSubAction::deleteSelection to EditSubAction::eDeleteSelectedContent r=m_kato
https://hg.mozilla.org/integration/autoland/rev/3b43794aa5cd
part 11: Rename EditSubAction::setTextProperty and EditSubAction::removeTextProperty to EditSubAction::eSetTextProperty and EditSubAction::eRemoveTextProperty r=m_kato
https://hg.mozilla.org/integration/autoland/rev/f276e2f986dd
part 12: Rename EditSubAction::outputText to EditSubAction::eComputeTextToOutput r=m_kato
https://hg.mozilla.org/integration/autoland/rev/33cc792b94aa
part 13: Rename EditSubAction::setText to EditSubAction::eSetText r=m_kato
https://hg.mozilla.org/integration/autoland/rev/a45bfcf3f9db
part 14: Rename EditSubAction::insertBreak to EditSubAction::eInsertParagraphSeparator r=m_kato
https://hg.mozilla.org/integration/autoland/rev/cb5ca0c5432e
part 15: Rename EditSubAction::makeList to EditSubAction::eCreateOrChangeList r=m_kato
https://hg.mozilla.org/integration/autoland/rev/e14543d6c02f
part 16: Rename EditSubAction::indent and EditSubAction::outdent to EditSubAction::eIndent and EditSubAction::eOutdent r=m_kato
https://hg.mozilla.org/integration/autoland/rev/9d204092ec62
part 17: Rename EditSubAction::align to EditSubAction::eSetOrClearAlignment r=m_kato
https://hg.mozilla.org/integration/autoland/rev/fab91b3a1ba9
part 18: Rename EditSubAction::makeBasicBlock to EditSubAction::eCreateOrRemoveBlock r=m_kato
https://hg.mozilla.org/integration/autoland/rev/83ad2703bd1a
part 19: Rename EditSubAction::removeList to EditSubAction::eRemoveList r=m_kato
https://hg.mozilla.org/integration/autoland/rev/88504d7d6794
part 20: Rename EditSubAction::makeDefListItem to EditSubAction::eCreateOrChangeDefinitionList r=m_kato
https://hg.mozilla.org/integration/autoland/rev/e14f374f66d2
part 21: Rename EditSubAction::insertElement to EditSubAction::eInsertElement r=m_kato
https://hg.mozilla.org/integration/autoland/rev/2416ffe8eb2e
part 22: Rename EditSubAction::insertQuotation to EditSubAction::eInsertQuotation r=m_kato
https://hg.mozilla.org/integration/autoland/rev/723f3296a72b
part 23: Rename EditSubAction::htmlPaste and EditSubAction::loadHTML to EditSubAction::ePasteHTMLContent and EditSubAction::eInsertHTMLSource r=m_kato
https://hg.mozilla.org/integration/autoland/rev/b7de3acd090e
part 24: Rename EditSubAction::resetTextProperties to EditSubAction::eRemoveAllTextProperties r=m_kato
https://hg.mozilla.org/integration/autoland/rev/8b288c890245
part 25: Rename EditSubAction::setAbsolutePosition and EditSubAction::removeAbsolutePosition to EditSubAction::eSetPositionToAbsolute and EditSubAction::eSetPositionToStatic r=m_kato
https://hg.mozilla.org/integration/autoland/rev/b6be0499ab6e
part 26: Rename EditSubAction::decreaseZIndex and EditSubAction::increaseZIndex to EditSubAction::eDecreaseZIndex and EditSubAction::eIncreaseZIndex r=m_kato
https://hg.mozilla.org/integration/autoland/rev/6639a257a37e
part 27: Replace EditSubAction::ignore with EditSubAction::eReplaceHeadWithHTMLSource and EditSubAction::eCreateBogusNode r=m_kato
https://hg.mozilla.org/mozilla-central/rev/1d39e0165b41
https://hg.mozilla.org/mozilla-central/rev/a653f964dbf8
https://hg.mozilla.org/mozilla-central/rev/14054ff18010
https://hg.mozilla.org/mozilla-central/rev/fba1566eb6a0
https://hg.mozilla.org/mozilla-central/rev/1e428fda3c71
https://hg.mozilla.org/mozilla-central/rev/432c41a3f433
https://hg.mozilla.org/mozilla-central/rev/e1135fe082bc
https://hg.mozilla.org/mozilla-central/rev/666cdc7ef8e2
https://hg.mozilla.org/mozilla-central/rev/a343a1752684
https://hg.mozilla.org/mozilla-central/rev/d2d0b0d3b43b
https://hg.mozilla.org/mozilla-central/rev/3b43794aa5cd
https://hg.mozilla.org/mozilla-central/rev/f276e2f986dd
https://hg.mozilla.org/mozilla-central/rev/33cc792b94aa
https://hg.mozilla.org/mozilla-central/rev/a45bfcf3f9db
https://hg.mozilla.org/mozilla-central/rev/cb5ca0c5432e
https://hg.mozilla.org/mozilla-central/rev/e14543d6c02f
https://hg.mozilla.org/mozilla-central/rev/9d204092ec62
https://hg.mozilla.org/mozilla-central/rev/fab91b3a1ba9
https://hg.mozilla.org/mozilla-central/rev/83ad2703bd1a
https://hg.mozilla.org/mozilla-central/rev/88504d7d6794
https://hg.mozilla.org/mozilla-central/rev/e14f374f66d2
https://hg.mozilla.org/mozilla-central/rev/2416ffe8eb2e
https://hg.mozilla.org/mozilla-central/rev/723f3296a72b
https://hg.mozilla.org/mozilla-central/rev/b7de3acd090e
https://hg.mozilla.org/mozilla-central/rev/8b288c890245
https://hg.mozilla.org/mozilla-central/rev/b6be0499ab6e
https://hg.mozilla.org/mozilla-central/rev/6639a257a37e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.