Closed Bug 1464244 Opened 2 years ago Closed Last year

Images in suspended background tabs will flicker/blink/flash after landing patches from bug #1176019 {browser.tabs.remote.tabCacheSize: 5}

Categories

(Core :: Graphics: Layers, defect, major)

62 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 + verified

People

(Reporter: Virtual, Assigned: dthayer)

References

Details

(Keywords: nightly-community, regression, reproducible, Whiteboard: gfx-noted [fixed by patch from bug #1465106])

1. Open some website page with many images
2. Open other tabs and browse it for some time,
so background tab with website page with images will suspended after some time
3. Go back to website page with many images
and see that images will flicker/blink/flash like they're rerendered/redownloaded
STR:
1. Open https://www.instagram.com/nana_eikura/ (no need loggin)
   Or about:home if you have Highlight thumbnails
   Or any other page with images
2. Open a New Tab in foreground tab
3. Wait for 2 minutes at least
4. Switch back to the tab of step1


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5e5ef53eee5b69f9be604029afa46ba0afb75966&tochange=9c10d9a7198331b7a650cef79ed37f36d23a2c88

Regressed by: Bug 1176019
Blocks: 1176019
Component: Tabbed Browser → Graphics: Layers
Flags: needinfo?(Virtual)
Product: Firefox → Core
Whiteboard: gfx-noted
Thank you very much Alice0775 White for finding specific regression range.
Has Regression Range: --- → yes
Flags: needinfo?(dothayer)
Keywords: reproducible
Summary: Images in suspended background tabs will flicker/blink/flash in Mozilla Firefox Nightly 62.0a1 → Images in suspended background tabs will flicker/blink/flash after landing patches from bug #1176019
Version: Trunk → 62 Branch
I can only seem to reproduce this on OSX - not on Windows. Just to confirm, Alice0775 what OS are you seeing this on?
Flags: needinfo?(alice0775)
(In reply to Doug Thayer [:dthayer] (PTO on May 17) from comment #4)
> I can only seem to reproduce this on OSX - not on Windows. Just to confirm,
> Alice0775 what OS are you seeing this on?

Win10 Home 64bit version 1803
Flags: needinfo?(alice0775)
Flags: needinfo?(dothayer)
Summary: Images in suspended background tabs will flicker/blink/flash after landing patches from bug #1176019 → Images in suspended background tabs will flicker/blink/flash after landing patches from bug #1176019 {browser.tabs.remote.tabCacheSize: 5}
Hey Doug, is this something you want to take? Not sure how critical this is. Thanks!
Flags: needinfo?(dothayer)
The LRU cache was disabled in bug 1465106, and should be disabled in today's Nightly. Virtual_ManPL, are you still seeing this?
Flags: needinfo?(dothayer) → needinfo?(Virtual)
Hmm, oddly, I can still reproduce this issue with Mozilla Firefox Nightly 62.0a1 (2018-05-30) (64-bit) on Windows 7 (64-bit) [ https://hg.mozilla.org/mozilla-central/rev/5866d6685849311f057e7e229b9ace63a2641c29 ].

@  Alice0775 White - Could you please retest it too and report back your results?
Flags: needinfo?(Virtual)
I can manage to reproduce the flickering on Win10 Nightly62.0a1 x64(20180529095249).
But, I can no longer reproduce on Win10 Nightly62.0a1 x64(20180530100110).
Of course, I can reproduce the issue on Nightly62.0a1 x64(20180530100110) if set browser.tabs.remote.tabCacheSize to 5.
Flags: needinfo?(alice0775)
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #8)
> Hmm, oddly, I can still reproduce this issue with Mozilla Firefox Nightly
> 62.0a1 (2018-05-30) (64-bit) on Windows 7 (64-bit) [
> https://hg.mozilla.org/mozilla-central/rev/
> 5866d6685849311f057e7e229b9ace63a2641c29 ].

Can you reproduce this if you switch tabs with ctrl+tab instead of clicking on them? I'm wondering if the 1176019 had some kind of side effect on tab warming.
Flags: needinfo?(Virtual)
(In reply to Doug Thayer [:dthayer] (PTO on June 4) from comment #10)
> (In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see
> your comment/reply/question/etc.) from comment #8)
> > Hmm, oddly, I can still reproduce this issue with Mozilla Firefox Nightly
> > 62.0a1 (2018-05-30) (64-bit) on Windows 7 (64-bit) [
> > https://hg.mozilla.org/mozilla-central/rev/
> > 5866d6685849311f057e7e229b9ace63a2641c29 ].
> 
> Can you reproduce this if you switch tabs with ctrl+tab instead of clicking
> on them? I'm wondering if the 1176019 had some kind of side effect on tab
> warming.

Yes, I can reproduce it now only if I will use Ctrl+Tab, clicking work fine. I will look on it deeper in next week.
Flags: needinfo?(Virtual)
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #11)
> (In reply to Doug Thayer [:dthayer] (PTO on June 4) from comment #10)
> > (In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see
> > your comment/reply/question/etc.) from comment #8)
> > > Hmm, oddly, I can still reproduce this issue with Mozilla Firefox Nightly
> > > 62.0a1 (2018-05-30) (64-bit) on Windows 7 (64-bit) [
> > > https://hg.mozilla.org/mozilla-central/rev/
> > > 5866d6685849311f057e7e229b9ace63a2641c29 ].
> > 
> > Can you reproduce this if you switch tabs with ctrl+tab instead of clicking
> > on them? I'm wondering if the 1176019 had some kind of side effect on tab
> > warming.
> 
> Yes, I can reproduce it now only if I will use Ctrl+Tab, clicking work fine.
> I will look on it deeper in next week.

Hmm, after some time and minimizing windows, it's also reproducible on clicking.
Setting to disable due to Bug 1465106.
It's still reproducible in some way for me, so I'm marking Firefox 62 as affected.
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #14)
> It's still reproducible in some way for me, so I'm marking Firefox 62 as
> affected.

In what way? if it's with browser.tabs.remote.tabCacheSize set to 5, please set back to disabled. That won't ride to release yet.
Flags: needinfo?(Virtual)
I didn't change "browser.tabs.remote.tabCacheSize" preference value and have it set as "0".
Flags: needinfo?(Virtual)
Hey dthayer - are you able to reproduce this at all on macOS with the cache set to 0?

We might want to consider just backing out the cache patch, since it's intended functionality is effectively disabled for now.
Flags: needinfo?(dothayer)
(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos / reviews) from comment #17)
> Hey dthayer - are you able to reproduce this at all on macOS with the cache
> set to 0?
> 
> We might want to consider just backing out the cache patch, since it's
> intended functionality is effectively disabled for now.

Yeah we can do that - I do first just want to try disabling one bit of code to check if this is responsible. I can't reproduce though, so Virtual, can you reproduce the problem with the following build?

https://queue.taskcluster.net/v1/task/O2yEsDJQR66UCoQNg23eWA/runs/0/artifacts/public/build/target.zip
Flags: needinfo?(dothayer) → needinfo?(Virtual)
(In reply to Doug Thayer [:dthayer] (PTO on June 4) from comment #18)
> (In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos /
> reviews) from comment #17)
> > Hey dthayer - are you able to reproduce this at all on macOS with the cache
> > set to 0?
> > 
> > We might want to consider just backing out the cache patch, since it's
> > intended functionality is effectively disabled for now.
> 
> Yeah we can do that - I do first just want to try disabling one bit of code
> to check if this is responsible. I can't reproduce though, so Virtual, can
> you reproduce the problem with the following build?
> 
> https://queue.taskcluster.net/v1/task/O2yEsDJQR66UCoQNg23eWA/runs/0/
> artifacts/public/build/target.zip

It's also reproducible with this build,
but I'm very sorry, Alice0775 White was right,
main bug isn't reproducible anymore and was like:
-no image
-image loads
-image reloads
now it only stayed:
-no image
-image loads
which wasn't caused by patches from bug #1176019,
but I will try to find cause of that issue too and report it in new created bug.
Thank you very much for your attention!
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(Virtual)
Resolution: --- → FIXED
Whiteboard: gfx-noted → gfx-noted [fixed by patch from bug #1465106]
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.