wrong z-order after scroll

VERIFIED FIXED in Firefox 61

Status

()

defect
P2
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: alice0775, Assigned: mattwoodrow)

Tracking

(Blocks 1 bug, {regression})

61 Branch
mozilla62
x86_64
Windows 10
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61+ verified, firefox62+ verified)

Details

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

a year ago
Steps to reproduce:
1. Open https://www.instagram.com/nana_eikura/
2. Key press [End] and then [Home]
3. Optionally, Repeat step 2

Actual Results:
Image z-order becomes wrong
See attached screenshot
Summary: trender → wrong z-order after scroll
(Reporter)

Comment 2

a year ago
Posted image screenshot
(Reporter)

Comment 3

a year ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6415ccbf739f36f71548540bd92c3b86ab9e1529&tochange=d112cf7b2b60e6244099dc3b599a2444ba0d1da3

Suspect: 99de9f5450d8	Matt Woodrow — Bug 1443027 - Fix the merging algorithm to pass the new tests correctly.
Blocks: 1443027
(Assignee)

Updated

a year ago
Assignee: nobody → matt.woodrow
Blocks: RDLbugs
Component: Layout → Layout: Web Painting
Priority: -- → P2
Flags: qe-verify+
Flags: in-testsuite?

Comment 5

a year ago
mozreview-review
Comment on attachment 8980489 [details]
Bug 1464288 - Make sure PreProcessDisplayLists logic for switching AGRs matches what ComputeRebuildRegion uses.

https://reviewboard.mozilla.org/r/246668/#review252852

LGTM.
Attachment #8980489 - Flags: review?(mikokm) → review+

Comment 6

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5033de939b8c
Make sure PreProcessDisplayLists logic for switching AGRs matches what ComputeRebuildRegion uses. r=miko

Comment 7

a year ago
Backout by ccoroiu@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/52654e368e83
Backed out changeset 5033de939b8c for failing reftests at reftest/tests/layout/reftests/display-list/1464288-1.htm a=backout
Comment hidden (mozreview-request)
(Assignee)

Comment 10

a year ago
(In reply to Dorel Luca [:dluca] from comment #8)
> Backed out changeset 5033de939b8c (bug 1464288) for failing reftests at
> reftest/tests/layout/reftests/display-list/1464288-1.htm a=backout 
> 
> Log:
> https://treeherder.mozilla.org/logviewer.
> html#?job_id=180267268&repo=autoland&lineNumber=9244
> 
> https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/
> reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/
> PGYO5FrqRFat8nIZJXOxJg/runs/0/artifacts/public/logs/live_backing.
> log&only_show_unexpected=1
> 
> Push with failures:
> https://treeherder.mozilla.org/#/
> jobs?repo=autoland&revision=5033de939b8c736d03821284fcdd1fd956ee06b6
> 
> Backout:
> https://hg.mozilla.org/mozilla-central/rev/
> 52654e368e83894860b228e1b08984c27104460a

Oh right, linux32 debug has APZ disabled. Forgot to condition the test on that.
Flags: needinfo?(matt.woodrow)

Comment 11

a year ago
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/18a7b3b1332d
Make sure PreProcessDisplayLists logic for switching AGRs matches what ComputeRebuildRegion uses. r=miko
Please request Beta approval on this when you get a chance.
Flags: needinfo?(matt.woodrow)

Comment 13

a year ago
Backout by dluca@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/e0beb6560ec9
Backed out changeset 18a7b3b1332d for failing reftests at reftest/tests/layout/reftests/display-list/1464288-1.htm a=backout
Comment hidden (mozreview-request)

Comment 16

a year ago
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4fe333a81f25
Make sure PreProcessDisplayLists logic for switching AGRs matches what ComputeRebuildRegion uses. r=miko

Comment 17

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4fe333a81f25
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
(Assignee)

Comment 18

a year ago
Comment on attachment 8980489 [details]
Bug 1464288 - Make sure PreProcessDisplayLists logic for switching AGRs matches what ComputeRebuildRegion uses.

Approval Request Comment
[Feature/Bug causing the regression]: Retained-dl
[User impact if declined]: Incorrect z-order sorting in some situations. Affect instagram, while logged out (at minimum).
[Is this code covered by automated tests?]: Yes, new reftest added.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Just increases the number of items we mark to account for async scrolling, no new code paths.
[String changes made/needed]: None.
Flags: needinfo?(matt.woodrow)
Attachment #8980489 - Flags: approval-mozilla-beta?
Flags: in-testsuite? → in-testsuite+
Comment on attachment 8980489 [details]
Bug 1464288 - Make sure PreProcessDisplayLists logic for switching AGRs matches what ComputeRebuildRegion uses.

RDL correctness fix with a new reftest included. Approved for 61.0b9.
Attachment #8980489 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I’ve tried to observe this issue on several platforms/test machines on the affected Nightly and 
Beta (included with japanese builds), but unfortunately, I couldn't reproduce its behavior. 

Alice, can you please, verify if this is still reproducible on your side, on the fixed Firefox builds? Thank you!
Flags: needinfo?(alice0775)
(Reporter)

Comment 22

a year ago
I can manage to reproduce the issue on Win10 x64 Nightly62.0a1(build ID 20180525005138) and 61.0b8(build ID 20180524181234).
And I verified to fix on Win10 x64 Nightly62.0a1(build ID 20180528220216) and 61.0b9(build ID 20180528091514).
Status: RESOLVED → VERIFIED
Flags: needinfo?(alice0775)
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.