Spell checker language setting is not remembered

RESOLVED FIXED in SeaMonkey2.63

Status

defect
RESOLVED FIXED
a year ago
4 months ago

People

(Reporter: petermad, Assigned: filleeeh)

Tracking

SeaMonkey 2.49 Branch
SeaMonkey2.63

SeaMonkey Tracking Flags

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.3
Build ID: 20180412182658

Steps to reproduce:

I change the language for the Spell checker to Danish in by opening the dropdown menu at the "Spell" button in the toolbar.


Actual results:

When the Check Spelling dialog opens, it is still set to English (United States).  Ihave to change to Danish in the Check Spelling dialog itself.

As long as I am editing the same message the Spelling dialog stays set to Danish when I reopen it the Check Spelling dialog.  But when I create a new message the settings for both Button dropdown menu and Check Spelling dialog is reset to English.


Expected results:

I expect the choice I make in the Button dropdown menu to be honored when the Check Spelling dialog is opened, and I expect that Seamonkey remembers the setting for the following new messages.
(Assignee)

Comment 1

6 months ago
Posted patch 1464605-spellchecklang.patch (obsolete) — Splinter Review
Is this considered a bug and something we would like to be fixed? I personally agree with the reporter that this should be addressed. I've taken the liberty to attach a patch with a simple fix - setting the same pref as found under Preferences -> Appearance -> Spelling, since this is already respected when opening the composer.
Status: UNCONFIRMED → NEW
Ever confirmed: true
> Is this considered a bug and something we would like to be fixed?

I would say yes but your patch does not set the actual pref for me in 2.53. You can observe this with about:config open. See no error in the log either.
(Assignee)

Comment 3

5 months ago
(In reply to Frank-Rainer Grahl (:frg) from comment #2)
> > Is this considered a bug and something we would like to be fixed?
> 
> I would say yes but your patch does not set the actual pref for me in 2.53.
> You can observe this with about:config open. See no error in the log either.

My apologies for the late reply.

I have tried the patch on both comm-esr52 and on comm-esr60 and it sets the pref correctly on both.
Could you please tell me which revision I should build to replicate the issue you are describing?

Just to be clear, here is a link to a GIF demonstating the patch applied to comm-esr52. It works the same on comm-esr60: https://imgur.com/a/ObGYsAJ
(Assignee)

Comment 4

5 months ago
Updated patch that also changes the pref when changing spell checker language from the spell check dialog (and not just the drop-down menu).

While not strictly the exact issue described in the bug report, I believe this is closely related enough to be included in the patch.

This patch is only applicable to comm-esr60 (and not esr52) as it builds on the changes made to the spell check dialog in Bug 1400646.
Attachment #9029398 - Attachment is obsolete: true

Comment 5

5 months ago
With me the pref in 2.53 are not set also.
But that could also be due to errors in 2.53.
With and without the patch I receive the following error messages in 2.53:

Timestamp: 14.12.2018, 00:35:47
Error: NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIInlineSpellChecker.spellCheckRange]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2163

Timestamp: 14.12.2018, 00:36:12
Error: TypeError: spellChecker is null
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2139

Timestamp: 14.12.2018, 00:36:17
Error: TypeError: spellChecker is null
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2151

Comment 6

5 months ago
sorry, that was fake news. 
Both patches work with version 2.53
Assignee: nobody → filleeeh
Status: NEW → ASSIGNED
Let me check it again.
Comment on attachment 9031130 [details] [diff] [review]
1464605-spellchecklang2.patch

Looks good. What I actually thought was not working was the missing fix for Bug 1400646 in 2.53.

Added this and Bug 1400646 backport to my 2.53 patch queue. Bills next build should pick them up.

IanN should we backport to 2.49.5 too?
Attachment #9031130 - Flags: review+
Attachment #9031130 - Flags: approval-comm-esr60?

Comment 9

5 months ago
Comment on attachment 9031130 [details] [diff] [review]
1464605-spellchecklang2.patch

a=me
Attachment #9031130 - Flags: approval-comm-esr60? → approval-comm-esr60+

Comment 10

4 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/6b7c8000a821
Remember spell check language in mailnews composer. r=IanN
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.