Closed Bug 1464649 Opened Last year Closed Last year

Upload error "Error: xhr onerror was called, xhr.statusText:" in Gecko Profiler after landing patch from bug #1434553

Categories

(Core :: Gecko Profiler, defect, P1, major)

62 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED DUPLICATE of bug 1464090

People

(Reporter: Virtual, Unassigned)

Details

(Keywords: nightly-community)

STR:
1. Catch profile with Gecko Profiler 0.22
2. Try to upload and share it
and see this message:
> Upload Error
> 
> An error occurred during upload:
> 
> Error: xhr onerror was called, xhr.statusText: 

Browser Console shows:
> Handler function threw an exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannelInternal.remoteAddress]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://devtools/shared/base-loader.js -> resource://devtools/shared/webconsole/network-monitor.js :: _onResponseHeader :: line 1382"  data: no]
> Stack: _onResponseHeader@resource://devtools/shared/base-loader.js -> resource://devtools/shared/webconsole/network-monitor.js:1382:5
> _dispatchActivity@resource://devtools/shared/base-loader.js -> resource://devtools/shared/webconsole/network-monitor.js:1024:9
> NetworkMonitor.prototype.observeActivity<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/webconsole/network-monitor.js:1086:7
> exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
> Line: 1382, column: 0 ThreadSafeDevToolsUtils.js:88:5
> Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://profile-store.appspot.com/compressed-store. (Reason: CORS request did not succeed).
> Error: xhr onerror was called, xhr.statusText: 758c92d1d77942324be3.bundle.js:20:24137
This is a regression from bug 1434553 and probably the same issue as bug 1464090.
Summary: Upload error "Error: xhr onerror was called, xhr.statusText:" with Gecko Profiler 0.22 in Mozilla Firefox Nightly 62.0a1 (2018-05-26) → Upload error "Error: xhr onerror was called, xhr.statusText:" in Gecko Profiler after landing patch from bug #1434553
Marking the dependency for now, but feel free to dupe if it proves to be the same issue.
Depends on: 1464090
Priority: -- → P1
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1464090
You need to log in before you can comment on or make changes to this bug.