Only use _NET_WM_BYPASS_COMPOSITOR hint with Basic compositor

RESOLVED FIXED in Firefox 65

Status

()

enhancement
P3
normal
RESOLVED FIXED
Last year
6 months ago

People

(Reporter: ryan.hendrickson, Assigned: ryan.hendrickson)

Tracking

60 Branch
mozilla65
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

I see from bug 1134077 that the _NET_WM_BYPASS_COMPOSITOR hint was added to Firefox windows to resolve video tearing; however, on versions of Firefox prior to 60, I didn't have any issues with fullscreen videos (I am admittedly voiding my warranty with media.hardware-video-decoding.force-enabled, which on my hardware is the only way I've found to get decent video performance at all). Since upgrading to 60, however, fullscreen videos have more latency and the video lags behind the audio, and I only just figured out that this change was to blame—when I remove that hint, video goes back to its pre-60 performance.

Can you please make this hint controllable with an about:config preference? I'm fine with the hint being present by default, since it seems like you have a logical justification for setting it, but at least for me (and I would assume some other power users as well), having the ability to disable it is necessary to make videos watchable on Firefox.
Component: General → Graphics
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [gfx-noted]
What is "Compositing" in about:support?

If it is not "Basic", then framebuffer updates probably are aligned with vblank, in which case _NET_WM_BYPASS_COMPOSITOR should not be set.
It would be better to do this automatically than to require an additional preference to be set.
Flags: needinfo?(ryan.hendrickson)
I have OpenGL for Compositing, so that sounds like a good idea to me!
Flags: needinfo?(ryan.hendrickson)
Attachment #9028375 - Attachment description: Bug 1464679 - X11: Add preference to control _NET_WM_BYPASS_COMPOSITOR hint. r?karlt → Bug 1464679 - X11: Only use _NET_WM_BYPASS_COMPOSITOR hint with Basic compositor. r?karlt
Blocks: 1134077
Keywords: checkin-needed
Summary: Control _NET_WM_BYPASS_COMPOSITOR hint with preference → Only use _NET_WM_BYPASS_COMPOSITOR hint with Basic compositor
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a0315e4606c7
X11: Only use _NET_WM_BYPASS_COMPOSITOR hint with Basic compositor. r=karlt
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a0315e4606c7
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Assignee: nobody → ryan.hendrickson
You need to log in before you can comment on or make changes to this bug.