Autoscroll is broken after switch tabs if HWA is disabled. And Right click Context menu does not pop up after scroll and switch tabs. {browser.tabs.remote.tabCacheSize: 5}

REOPENED
Unassigned

Status

()

defect
P3
major
REOPENED
Last year
Last year

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

62 Branch
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62 disabled)

Details

Attachments

(2 attachments)

I can reproduce the issue on Linux Mint 18.3 MATE edition and Windows10 Home x64 if HWA is disabled.


Reproducible: always

Steps To Reproduce:
1. Enable Autoscroll from about:preferences#general
2. Open webpage such as http://archive.mozilla.org/pub/mozilla.org/firefox/nightly/
3. Open webpage such as http://archive.mozilla.org/pub/mozilla.org/firefox/nightly/ in a new tab

4. Middle click on the page and perform autoscroll to the page bottom or the page top
   --- observe, Autoscroll marker position
5. Left click to stop autoscroll when page reached at the page bottom or the page top

6. Switch to the other tab
8. Repeat from step 4  (at least 2-3 times)

Actual Results:
Autoscroll marker pops up at wrong place.
So, autoscroll is performed wrong way

Expected Results:
Autoscroll marker should pop up at the position of middle clicking.


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5e5ef53eee5b69f9be604029afa46ba0afb75966&tochange=9c10d9a7198331b7a650cef79ed37f36d23a2c88

Regressed by:Bug 1176019
Component: General → Graphics: Layers
Product: Firefox → Core
Version: Trunk → 62 Branch
[Tracking Requested - why for this release]: broken autoscroll

Doug Thayer,
Your bunch of patch seems to cause the regression, could you please look into this issue?
Flags: needinfo?(dothayer)
Posted video screencast
Summary: Autoscroll is broken after switch tabs → Autoscroll is broken after switch tabs if HWA is disabled
Steps To Reproduce:
0. Disable HWA if any. And restart
1. Enable Autoscroll from about:preferences#general
2. Open webpage such as http://archive.mozilla.org/pub/firefox/candidates/
3. Open webpage such as http://archive.mozilla.org/pub/firefox/candidates/ in a new tab

4. Middle click on the page and perform autoscroll to the page bottom or the page top
   --- observe, Autoscroll marker position
5. Left click to stop autoscroll when page reached at the page bottom or the page top

6. Switch to the other tab
7. Repeat from step 4  (at least 2-3 times)
[Tracking Requested - why for this release]: Right click context menu is also broken.

Steps To Reproduce:
0. Disable HWA if any. And restart
1. Enable Autoscroll from about:preferences#general
2. Open webpage such as http://archive.mozilla.org/pub/firefox/candidates/
3. Open webpage such as http://archive.mozilla.org/pub/firefox/candidates/ in a new tab

4. Middle click on the page and perform autoscroll to the page bottom
5. Left click to stop autoscroll when page reached at the page bottom

6. Switch to the other tab
7. Middle click on the page and perform autoscroll to the page bottom
8. Left click to stop autoscroll when page reached at the page bottom

9. Switch to the other tab
10. Middle click on the page and perform autoscroll to the page top
11. Left click to stop autoscroll when page reached at the page top

12. Switch to the other tab
13. Right click on the content area
   ---- observe, ContentArea context menu

Actual Results;
No context menu pops up.

Expected Results:
ContentArea context menu should open at the mouse pointer.
Severity: normal → major
Summary: Autoscroll is broken after switch tabs if HWA is disabled → Autoscroll is broken after switch tabs if HWA is disabled. And Right click Context menu does not pop up after scroll and switch tabs.
Hi Everyone, i managed to reproduce this issue using Nightly 62.0a1 (2018-05-29).
Please note that it reproduces more easily if the user clicks somewhere on the Taskbar or the Top menu bar when stopping the Autoscroll with a left click.
This should go away on Nightly with bug 1465106 - adding the controlling pref to the title to be clear about how to reproduce this.
Flags: needinfo?(dothayer)
Summary: Autoscroll is broken after switch tabs if HWA is disabled. And Right click Context menu does not pop up after scroll and switch tabs. → Autoscroll is broken after switch tabs if HWA is disabled. And Right click Context menu does not pop up after scroll and switch tabs. {browser.tabs.remote.tabCacheSize: 5}
Let's call this a P3 and close as a DUPE or WFM if it goes away via bug in comment 7.
Priority: -- → P3
See Also: → 1465106
Alice, can you check in the latest Nightly? THanks!
Flags: needinfo?(alice0775)
I can manage to reproduce the issue on the following build[1].
And I verified to fix the issue on the following build[2]. 

[1]
Windows 10 Nightly62.0a1 x64 (20180523100147) With HWA is disabled.
Linux Mint 18.3 MATE edition Nightly62.0a1 x64 (20180523100147) With HWA is blacklisted.
[2] 
Windows 10 Nightly62.0a1 x64 (20180530100110) With HWA is disabled.
Linux Mint 18.3 MATE edition Nightly62.0a1 x64 (20180530100110) With HWA is blacklisted.


Fixed by Bug 1465106.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(alice0775)
Resolution: --- → FIXED
This is still a valid bug with browser.tabs.remote.tabCacheSize = 5.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You need to log in before you can comment on or make changes to this bug.