Closed Bug 1464726 Opened 3 years ago Closed 3 years ago

Flex column overflow cropped in print

Categories

(Core :: Printing: Output, defect)

60 Branch
Unspecified
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1622935
Tracking Status
firefox-esr52 --- affected
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected

People

(Reporter: ngistatonaquitallizom, Unassigned)

Details

Attachments

(1 file)

Attached file print-flex-column.html
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180503143129

Steps to reproduce:

* Open attached file "firefox-print-flexbox.html"
* Print onto an A4 portrait page.


Actual results:

Only a single page is visible instead of 3 pages.


Expected results:

From what I can tell by reading the standard, flex items should overflow in the flex-end direction, which means that items should be visible on the next page, even though the flex container seems to be cropped to a single page.

https://www.w3.org/TR/css-flexbox-1/

I've tried playing around with various page-break-* and overflow combinations and I couldn't find a way to avoid the issue.

I've tested on Debian 9 in FF ESR v52.8.0 & FF Snap v60.0-2 Rev 85

And the same file works just fine in Chromium or other browsers.
Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0 (20180531101452)

I have tested this report on Ubuntu 18.04 using latest Nightly and Firefox release build. I was able to reproduce the mentioned behavior on Ubuntu, Windows, and Mac OS. When I open the attached file "print-flex-column.html" and try to print it, only the first page is printed instead of all three pages. 

As mentioned, the same file is printed correctly using Chrome browser.
Status: UNCONFIRMED → NEW
Component: Untriaged → Printing
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Toolkit
This appears to be a bug in our printing engine, and not the printing UI under Toolkit.
Component: Printing → Printing: Output
Product: Toolkit → Core
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939897

The test case contains a single-line column flex container. Printing it is fixed by bug 1622935.

Duplicate of bug: 1622935
You need to log in before you can comment on or make changes to this bug.