stylesheets with international characters do not load in unicode pages

RESOLVED DUPLICATE of bug 128896

Status

()

--
minor
RESOLVED DUPLICATE of bug 128896
17 years ago
17 years ago

People

(Reporter: peregil, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020501
BuildID:    Mozilla 0.9.9 Gecko/20020501

If the stylesheet contains international characters (like the norwegian רזו -
usually in comments) the stylesheet will not load if charset of the html-page is
set to utf-8. 

Reproducible: Always
Steps to Reproduce:
1.Make stylesheet with the norwegian character "ר" in a comment
2.Set charset to utf-8 in meta-tag in html header



Here is the code in the html-header that does not work
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<link rel="stylesheet" type="text/css" href="stylesheet.css">

Comment 1

17 years ago
This sounds like bug 128896 but that is marked as fixed sometime before your build was created....
(Reporter)

Comment 2

17 years ago
You are right. It looks like the same bug.

It does not seem to be fixed on Linux. (I tested on latest Windows RC2, and had
no problems). I even upgraded my Linux browser to the latest Red
Carpet/Ximian-version for Redhat 7.2. (Dont have the build date here). 

This testcase from bug 128896 shows the problem:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=72507

Comment 3

17 years ago
Changing QA contact to Amar
QA Contact: petersen → amar

Comment 4

17 years ago
This should go to either style system or internationalization. Changing this bug 
to style system first.
Component: Layout → Style System
QA Contact: amar → madhur

Comment 5

17 years ago
Testcase attachment 72507 [details] from bug 128896 is working fine on RedHat linux 7.3 :  
build 2002-05-28_07trunk as well as on win2000 : build 2002-05-28_07trunk

Reporter, do u still see this bug? If you do, please provide a new testcase 
showing the problem.

Thx!!

*** This bug has been marked as a duplicate of 128896 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.