Biff causes "failed to connect to server" message when no connection is available

VERIFIED DUPLICATE of bug 123440

Status

VERIFIED DUPLICATE of bug 123440
17 years ago
10 years ago

People

(Reporter: bugzilla3, Assigned: mscott)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
A recent re-incarnation of a bug that I can't recall. Steps to reproduce:
1. Close internet connection.
2. Activate biff ("check for new mail every x minutes") if it wasn't already
activated.
3. Close Mozilla and restart it. Alternatively, wait until "x" minutes timeout.

Expected results: biff doesn't trigger pop-up alert.

Actual results: biff triggers a "failed to connect to server ..." pop-up.

Seeing it on 2002052208, Win2K.
(Reporter)

Updated

17 years ago
Keywords: regression

Updated

17 years ago
QA Contact: gayatri → gchan

Comment 1

17 years ago
Reporter can you clarify some things please?

What do you mean by close internet connection? As in
you are not connected to internet/isp provider when you are
doing these steps? But you see pop up alert in the bottom
right hand corner popping up?

What is the user agent string for the build you are using?
(do about mozilla to get agent string). I'm trying to figure
out if you are on the branch or trunk build.

is this for imap or pop accnt?

This is what I did using trunk build:
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0+)Gecko/20020521

1.I set for both imap & pop acnts: biff settings for 1 min.
2.quit
3.Pulled out my network connection to the computer.
4.Started mozilla
5.Did not go offline (which is what you are supposed to do
  if not connected to the network)
6.Clicked messenger.
7. waited

after min or so: I get this alert mesg: Failed to connect to server <servername>

Which is expected because you browser is 'online' trying to connect to 
mail server
but your computer doesn't have network connection. So we are telling
you it failed to connect. So it's not a error.

You're not talking about animated pop up alert that appears above
sytem tray when new messages arrive correct?


(Reporter)

Comment 2

17 years ago
It is about the "Failed to connect to server <servername>" alert you also saw
after the steps you described. And, finally I found the old bug I was talking
about. It's bug 123440 and 4xp btw. That bug is identical to this one, that is
why I added the "regression" keyword before.
Keywords: 4xp

Comment 3

17 years ago
Reporter,
That mesg is supposed to appear if you aren't connected to network
but you try to start mail while still in online mode. 

I tried both checked/uncheckd pref (check for new mail every x minutes)
and in both cases the alert (Failed to connect to server <servername>)
came up the same number of times, once.

Are you saying that this 'Failed to connect' message appears every x
minutes based on your biff setting? I don't see this.

Are you using trunk or branch?
(Reporter)

Comment 4

17 years ago
It's my fault that I didn't make things clear in the initial report. I use pop.
A better procedure to reproduce what I'm seeing: 
1. Have the biff to check for new messages every x minutes.
2. Activate internet connection (alternatively, do that after starting Mail). 
3. Start Mail, wait for messages to download (you're in online mode).
4. Close internet connection, in order to read your messages. That is the
standard behaviour if you have to read a lot of messages every day and you 're
paying per connection time.

Expected behaviour: no "fail to connect to server..." alerts.
Actual behaviour: the above alert appears every x minutes.

As you see, I'm not using off-line mode. I tried a new profile (with same biff
settings), and got the same annoying result. I download trunk builds every day
and this behaviour started somewhere in the last week. Currently using
2002052508 trunk (from ftp.mozilla.org/pub/mozilla/nightly/latest/, as usual).
After reverting to 2002051308, I am seeing expected behaviour. Please use a
build prior to May 21 (approximately) and you 'll notice the difference.

Comment 5

17 years ago
Ok confirmed reporter's bug based on comment 4.
I was able to reproduce using 2002052408 commercial trunk on nt 4.0

Using a pop mail account:
After disconnecting to network (but still in online mode), if
I wait minute or two I would see this error mesg:
   Could not connect to server <servername> the connection was refused
or sometimes:
   Conncetion to server <servername> timed out

Course the same thing happens to imap mail account also.

Sheela do you know of any pop bugs for this?

Scott, I still question if this is a error? I think because
we have the pref (check for new mesgs every x minutes) for pop or imap
that we should generate this error. If you're not connected to network
then the user should have browser/messenger in offline mode. When
you set that pref, we assume you ARE CONNECTED to network. So it checks
ever x minutes and when it can't connect to the mail server, we generate
the error.

I have also confirmed using (20020517 commercial trunk) and (20020524
commercial trunk) for Mac os 10.1.4, that the error mesg did not appear
in 5-17 builds but does in 5-24 builds.

Not sure what changed?

Comment 6

17 years ago
gchan,
I think this is a valid bug. I ran a query on the open bugs on pop and was not
able to find anything.  Also this is more a biff problem even though this has
been reported on a pop account. 
Biff should not be throwing any alerts and this can really get very annoying.  
This bug is very much like bug 123440 which probably is a recent regression.
I checked this on today's branch build on win98 and did not see this behavior. 
So this could be on the trunk only.  

Comment 7

17 years ago
Actually, I did find something with not much information at all in the bug.  I
will dup that bug for this since this has more info.
The bug number is 118672

Comment 8

17 years ago
*** Bug 118672 has been marked as a duplicate of this bug. ***
over to biff component.
Component: Mail Back End → Mail Notification
QA Contact: gchan → stephend

Comment 10

17 years ago
Bug 118672 is not windoze-only.

Comment 11

17 years ago
Bug 118672 is not a dupe. OS/2 trunk builds are not broken.
(Reporter)

Comment 12

17 years ago
Finally I think I must dup this one against bug 123440. It seems that the
difference between the two bugs is on the kind of annoyance. I am annoyed of the
alert because most of the time I read or compose mail while I'm not connected on
my dial-up isp. In bug 123440, the reporter is annoyed because the autodownload
feature doesn't work after the first connection failure (because he doesn't
dismiss the alert).

Sheela, gchan what do you think about it? I am asking because I am willing to
make this bug fixed. I haven't tried to code for Mozilla before but I think this
is a good chance. Not sure if I 'll succeed (probably not), but I want give it a
shot.

It's the greatest annoyance for me, at the moment, making emailing a misery for
my home dialup connection. Autodownload is off by default, that is why I think
most users don't notice this bug. Of course, there isn't even the slightest
chance for a lan/high bandwidth user to get into this. Otoh, there is a
workaround (uncheck autodownload) but I find it unacceptable.

Comment 13

17 years ago
I'd like to second the call for this bug to be fixed. It worked fine in Moz 1.0
which I was using until yesterday when I upgraded to Moz 1.1beta.

Having auto-download in the background is the most useful way to run a mail
client, in my opinion. To have this regularly report spurious errors for dial-up
users is completely unacceptable.

Good luck Dimitrios.
OS: Windows 2000 → All
Hardware: PC → All

Comment 14

16 years ago
I don't know why Dimitrios didn't duplicate this when he posted comment 12, but 
I'm dup'ing it now.

chris@eclipse.promail.com, you may wish to move your vote.


*** This bug has been marked as a duplicate of 123440 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.