Closed Bug 14652 Opened 21 years ago Closed 20 years ago

Clicking return on a bullet did not create a new bulleted line

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 15832

People

(Reporter: bijals, Assigned: mozeditor)

Details

Steps:
1) Launch Editor
2) On the first sentence, click the bullet icon
3) On the new bulleted first sentence, place cursor any where in the sentence
4) Click return

Actual Results: First sentence is split into two lines, but the second line is
not bulleted

Expected:  Two lines with bullets

Build Date and Platform: 1999092208 on WinNT
Assignee: buster → jfrancis
Target Milestone: M15
it's because we're making a list out of a <P>.  There needs to be some way to
make it obvious to the user what's going on here.  Right now, it's
undiscoverable why one paragraph (with a <P>) would work, and why another (with
a <DIV>) would work.
Status: NEW → ASSIGNED
this problem will become less likely with the new div/br rules.  I unwrap all
mozdivs going into a list item, and rewrap them if you unlist it.  So you get
list like behavior on returns.

But I still don't do that with paragraphs.  However, there won't be an easy way
to make paragraphs, so I'm not sure that's a problem for mail compose.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
dup of 15832


*** This bug has been marked as a duplicate of 15832 ***
Status: RESOLVED → VERIFIED
verified in 11/29 build.
You need to log in before you can comment on or make changes to this bug.