Mozilla browser crashed when viewing the URL listed.

RESOLVED DUPLICATE of bug 124596

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 124596
16 years ago
13 years ago

People

(Reporter: David H. Wagner, Assigned: Matti)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc3)
Gecko/20020521
BuildID:    2002052105

Mozilla browser crashed when viewing the URL listed.  Mac OS X console crash report:
Date/Time:  2002-05-23 15:20:25 -0500
OS Version: 10.1.4 (Build 5Q125)
Host:       d189.dhcp.math.uh.edu

Command:    Mozilla
PID:        4278

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x01f07814 in HandleScrollEvent(unsigned short, int, int, Point, nsIWidget *)
 #1   0x01f09974 in nsMacEventHandler::Scroll(unsigned short, int, Point const &)
 #2   0x01f03b00 in nsMacWindow::ScrollEventHandler(OpaqueEventHandlerCallRef *)
 #3   0x73118b08 in DispatchEventToHandlers
 #4   0x73101d98 in SendEventToEventTargetInternal
 #5   0x731b65b8 in SendEventToEventTarget
 #6   0x7310d740 in HandleMouseEvent
 #7   0x731ac034 in ToolboxEventDispatcherHandler
 #8   0x73118bb4 in DispatchEventToHandlers
 #9   0x73101d98 in SendEventToEventTargetInternal
 #10  0x731b65b8 in SendEventToEventTarget
 #11  0x731d2910 in ToolboxEventDispatcher
 #12  0x731cfc7c in CallEventDispatchHook
 #13  0x73179468 in GetOrPeekEvent
 #14  0x731a1468 in GetNextEventMatchingMask
 #15  0x731ae408 in WNEInternal
 #16  0x731c5508 in WaitNextEvent
 #17  0x01f0d980 in nsMacMessagePump::GetEvent(EventRecord &)
 #18  0x01f0d85c in nsMacMessagePump::DoMessagePump(void)
 #19  0x01f0d1ec in nsAppShell::Run(void)
 #20  0x01e22acc in nsAppShellService::Run(void)
 #21  0x004c9efc in main1(int, char **, nsISupports *)
 #22  0x004ca93c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005b34 in mach_msg_overwrite
 #2   0x70035e5c in lu_gethostbyname
 #3   0x70036318 in gethostbyname
 #4   0x705592f0 in BSD_gethostbyname_r
 #5   0x70558098 in AsyncInetStringToAddress
 #6   0x705594d4 in CarbonOperationThreadFunc
 #7   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x01f07814 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000018   lr: 0x01f09974  ctr: 0x01f09940   mq: 0x00000000
    r0: 0x00000000   r1: 0xbfffed70   r2: 0x01f4a000   r3: 0x00000000
    r4: 0xbfffedb4   r5: 0x00000003   r6: 0x00000001   r7: 0x00000000
    r8: 0xbfffed78   r9: 0x00000000  r10: 0x000001ce  r11: 0x000101b8
   r12: 0x01f43bc4  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000004
   r20: 0x00000000  r21: 0x00000001  r22: 0x75aea3e1  r23: 0x00000000
   r24: 0x00000000  r25: 0x03f95354  r26: 0x020b8570  r27: 0xbfffefe8
   r28: 0x00000003  r29: 0x00000000  r30: 0x000000ee  r31: 0x000001b8

**********



Reproducible: Couldn't Reproduce

Expected Results:  Not crashed.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 124596 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Mozilla browser crashed when viewing the URL listed. → Mozilla browser crashed when viewing the URL listed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.