Closed Bug 1465403 Opened 2 years ago Closed 11 months ago

MacOS menu and touchbar icons are blurry when SVG is used

Categories

(Core :: Widget: Cocoa, defect, P3)

defect
Points:
2

Tracking

()

RESOLVED FIXED
mozilla70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox70 --- fixed

People

(Reporter: ntim, Assigned: harry)

References

Details

Attachments

(2 files)

No description provided.
What icons is this referring to? If the size of the SVG is doubled and then scaled to 50%, does this reproduce?
Flags: needinfo?(ntim.bugs)
There are quite a few SVG bugs open for the SVG being rendered in images at the wrong resolution. For example, bug 986403. Several years ago I dug into one of them a bit, but every time I got to an "ah-hah, got it!" moment, it turned out not to be a red herring. From what I recall I last suspected that on HiDPI we were doing something wrong somewhere with CSS px to dev pixel conversion, but I never tracked down the source of the bug I was looking into at the time.
(In reply to Stephen A Pohl [:spohl] from comment #1)
> What icons is this referring to? If the size of the SVG is doubled and then
> scaled to 50%, does this reproduce?

The icons in the "Bookmarks" menu, this is mostly visible if you enable a dark menu bar on macOS.

Yes, it works if we double the size of SVG from 16 to 32, but it would be nice if the widget code handled this without such hacks.
Flags: needinfo?(ntim.bugs)
Priority: -- → P3
Bug 1174284 is technically for a different problem but I think the comments there outline how to fix this in the widget code.
See Also: → 1174284
Duplicate of this bug: 1472568
Summary: MacOS menu icons are blurry when SVG is used → MacOS menu and touchbar icons are blurry when SVG is used
Blocks: 1521893
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 70.3 - Aug 5 - 18
Points: --- → 2
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9154f62e7c76
Support loading icons @2x in macOS menu bars. r=mstange
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
QA Whiteboard: [qa-70b-p2]
You need to log in before you can comment on or make changes to this bug.