Closed Bug 1465537 Opened Last year Closed Last year

private browsing mode broken

Categories

(WebExtensions :: General, defect, P1)

x86_64
All
defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62+ verified)

VERIFIED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 + verified

People

(Reporter: buggyz, Assigned: aswan)

References

Details

(Keywords: nightly-community, regression, regressionwindow-wanted)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20100101

Steps to reproduce:

Updated firefox Nightly to version of 29-05-2018.


Actual results:

Firefox will not load any pages (i always browse in private browsing mode).

When surfing to - for instance - https://www.bonnieradvocaten.nl the loading icon in the tab appears but nothing else happens.

Also Firefox Nightly has filled up my SSD twice today writing 2 TB of date to it :(

When i Start Firefox nightly AFTER starting firefox stable for the first time Firefox Nightly does work.

Please also see:
https://www.reddit.com/r/firefox/comments/8n3co2/firefox_nightly_not_loading/




Expected results:

Firefox should not fill up my SSD and should load pages.
Has Regression Range: --- → yes
OS: Unspecified → All
Hardware: Unspecified → x86_64
I'm using Linux but this problem seem's to also affect Windows.
buggyz, which version of Windows? And, which particular Linux?

Andrei, can your team have a look at whether private browsing is broken on Linux?
Flags: needinfo?(buggyz)
Flags: needinfo?(andrei.vaida)
Xubuntu 18.04 and Windows 10

I would like to reiterate that after starting Firefox Nightly for the first time, it seems to work normally, the following page will load normally:
https://www.mozilla.org/en-US/firefox/62.0a1/whatsnew/?oldversion=60.0.1

Starting it for a second time no page will load.
Flags: needinfo?(buggyz)
buggyz, do you use the same data profile for Firefox and Firefox Nightly or do you use separate profiles? Thanks
Flags: needinfo?(buggyz)
I use the same profile for both FF and Nightly.
Flags: needinfo?(buggyz)
(In reply to buggyz from comment #5)
> I use the same profile for both FF and Nightly.

This is not a scenario we support as we do not support downgrading profiles, using the same profile between Firefox and Firefox Nightly is a scenario that leads to profile corruption, see https://wiki.mozilla.org/Nightly#Platform_specific_instructions

I am going to close this bug as invalid since what you are seeing is likely the consequence of profile corruption. If you can reproduce the bug with a new profile (not shared with Firefox Release), then feel free to reopen it.

Thanks for flagging the issue though!
Status: UNCONFIRMED → RESOLVED
Has Regression Range: yes → no
Closed: Last year
Flags: needinfo?(andrei.vaida)
Resolution: --- → INVALID
I can reproduce this issue with a new profile not shared with Firefox Release.

It's the combination of using "Always use private browsing mode" and using Addons. 

If Addons / Extensions are enables when using "Always use private browsing mode" no page will load
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
If addons are all removed everything works as expected even when Always using private browsing mode.
Thanks, I can confirm the bug! Private browsing mode is broken when it is set as the default mode for all browsing activities, not when it is ponctually.

Could you try to pinpoint the addon causing the bug? Disable half of your addons then test that it works. If if works then the addon causing the bug is in the other half, if it doesn't work disable another half of the addons etc.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Pascal Chevrel:pascalc from comment #9)
> Thanks, I can confirm the bug! Private browsing mode is broken when it is
> set as the default mode for all browsing activities, not when it is
> ponctually.
> 
> Could you try to pinpoint the addon causing the bug? Disable half of your
> addons then test that it works. If if works then the addon causing the bug
> is in the other half, if it doesn't work disable another half of the addons
> etc.

Actually i think its any Addon.
I've tried "Ublock Origin" "HTTPS-Everywhere" AND "Stop Facebook Tracking" and they all cause this behavior when persistently using Private browsing mode.
OK, I found in my own profile which addon causes the bug (could be triggered by other addons), in my case it is Facebook Container

STR:
1/ Install the Facebook container add-on https://www.mozilla.org/en-US/firefox/facebookcontainer/
2/ In about:preferences#privacy in the History section, select "Always use private browsing mode"
3/ Restart the browser
4/ Visit a webpage

ER:
Page loads

AR:
Page doesn't load, the spinner loads indefinitely in the tab header
Given that this is a mozilla add-on, maybe we should track it for 62, what do you think Liz?
Flags: needinfo?(lhenry)
Luke, can you take a look at this or help us find the right owner for this issue?
Flags: needinfo?(lhenry) → needinfo?(lcrouch)
regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6b406fa5a8a35fe00792d698bedd58eef07ad367&tochange=120d17a176ffa033fe79632804755ae23940c336

suspect: Bug 1460610:

@Kris Maglione
Your patch seems to cause the regression. Can you please look into this?
Blocks: 1460610
Component: Untriaged → Private Browsing
Flags: needinfo?(kmaglione+bmo)
(In reply to Alice0775 White from comment #14)
> regression window:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=6b406fa5a8a35fe00792d698bedd58eef07ad367&tochange=120d
> 17a176ffa033fe79632804755ae23940c336
> 
> suspect: Bug 1460610:
> 
> @Kris Maglione
> Your patch seems to cause the regression. Can you please look into this?

I don't want to say that that's not possible, but that's not possible. It's a one-line change that's a no-op if extensions are already installed.
Flags: needinfo?(kmaglione+bmo) → needinfo?(aswan)
(In reply to Kris Maglione [:kmag] (PTO through 06/05) from comment #15)
> (In reply to Alice0775 White from comment #14)
> > regression window:
> > https://hg.mozilla.org/integration/mozilla-inbound/
> > pushloghtml?fromchange=6b406fa5a8a35fe00792d698bedd58eef07ad367&tochange=120d
> > 17a176ffa033fe79632804755ae23940c336
> > 
> > suspect: Bug 1460610:
> > 
> > @Kris Maglione
> > Your patch seems to cause the regression. Can you please look into this?
> 
> I don't want to say that that's not possible, but that's not possible. It's
> a one-line change that's a no-op if extensions are already installed.


via local build,
Last good : ba76eaa4b71a
First bad : 120d17a176ff

So, the patch[1] of Bug 1460610 definitely cause the regression.

[1]
120d17a176ff	Kris Maglione — Bug 1460610: Fix content process whitelist for profile extensions when none are present at startup. r=aswan
Duplicate of this bug: 1466382
Hm, I don't have it completely figure out but webextensions delayed background startup uses the sessionstore-windows-restored notification.  When running with the STR from comment 11, that event is triggered before this code runs:
https://searchfox.org/mozilla-central/rev/292d295d6b084b43b70de26a42e68513bb7b36a3/toolkit/components/extensions/parent/ext-toolkit.js#86

Apparently SessionStore.jsm emits that event differently (or specifically, earlier during startup) in private browsing mode, and I guess the changes in bug 1460610 delay extension startup just enough to cause us to miss the event.  This means that background pages never get started.  Facebook Container, uBlock, and the other extensions mentioned here all use blocking webRequest listeners so web requests just hang forever.

I'll figure out a place to move browserStartupPromise so that we can get it reliably, in the mean time if you are affected by this you can set the preference extensions.webextensions.delayed-background-startup to false to avoid it.
Assignee: nobody → aswan
Component: Private Browsing → WebExtensions: General
Flags: needinfo?(aswan)
Priority: -- → P1
Product: Firefox → Toolkit
"Tree Style Tab" ver 2.4.24 is also affected in Always start with Private Browsing Mode. 
Tabs would not render in sidebar.  Ping-pong is displayed forever on the TST side bar.
And I also confirmed regression range is in comment 14 and comment 16.
Attachment #8983131 - Flags: review?(tomica)
Comment on attachment 8983131 [details]
Bug 1465537 Move browser startup promises to ExtensionParent.jsm

https://reviewboard.mozilla.org/r/248964/#review255162
Attachment #8983131 - Flags: review?(tomica) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81b41583c253
Move browser startup promises to ExtensionParent.jsm r=zombie
https://hg.mozilla.org/mozilla-central/rev/81b41583c253
Status: NEW → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Reproduced in Firefox 62.0a1(20180530100110).
Retested and verified using: "Facebook Container", "Https Everywhere", "Tree Style Tab", "uBlock Origin" in Firefox 62.0a1 (20180608100105) on Windows 10 64Bit, MacOS 10.13.4.
Product: Toolkit → WebExtensions
Flags: in-qa-testsuite?
Flags: in-qa-testsuite? → in-qa-testsuite+
Flags: needinfo?(lcrouch)
Verified as fixed based on comment #24
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.