Disable browser.startup.blankWindow on all channels except Nightly

VERIFIED FIXED in Firefox 61

Status

()

defect
P1
blocker
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

unspecified
Firefox 62
Points:
---

Firefox Tracking Flags

(firefox61blocking verified, firefox62 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 months ago
See bug 1447719 comment 19. UX has made it pretty clear to me that this can't ship in 61 as is.

[Tracking Requested - why for this release]:

The feature is currently enabled by default on Windows on Beta, and is configured to ride out to release. We should ensure we disable it before then.
(Assignee)

Updated

11 months ago
See Also: → 1447719
Assignee: nobody → mconley
Severity: normal → blocker
Priority: -- → P1

Comment 2

11 months ago
mozreview-review
Comment on attachment 8982013 [details]
Bug 1465583 - Disable early blank first paint on all channels except Nightly.

https://reviewboard.mozilla.org/r/248056/#review254210
Attachment #8982013 - Flags: review?(felipc) → review+

Comment 3

11 months ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5fce116c9fd
Disable early blank first paint on all channels except Nightly. r=Felipe

Comment 4

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e5fce116c9fd
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
(Assignee)

Comment 5

11 months ago
Comment on attachment 8982013 [details]
Bug 1465583 - Disable early blank first paint on all channels except Nightly.

Approval Request Comment
[Feature/Bug causing the regression]:

Bug 1447719 - the early first blank paint perceived performance feature.

[User impact if declined]:

Users on Windows will see a start-up sequence that UX isn't super jazzed about.

[Is this code covered by automated tests?]:

Start-up is definitely something that our automated tests go through. This also puts us back into a configuration that we've been shipping for years and years.

[Has the fix been verified in Nightly?]:

No, since the fix only takes affect on Beta (as the feature is now being held to Nightly and shut off in Beta).

[Needs manual test from QE? If yes, steps to reproduce]: 

Couldn't hurt. I believe ciprian_georgiu already did QA on the feature, so it should be straight-forward to test that the feature has been disabled.

[List of other uplifts needed for the feature/fix]:

None.

[Is the change risky?]:

No.

[Why is the change risky/not risky?]:

Simple pref flip back to a configuration that we've shipped for a long time.

[String changes made/needed]:

None.
Attachment #8982013 - Flags: approval-mozilla-beta?
Comment on attachment 8982013 [details]
Bug 1465583 - Disable early blank first paint on all channels except Nightly.

Avoids shipping a new feature that isn't ready yet. Approved for 61.0b11.
Attachment #8982013 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I managed to reproduce the issue using Fx 61.0b5 (the browser.startup.blankWindow is set to 'true' by default).
I have tested the fix with Firefox 61.0b13 on all 3 platforms: Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.10. The browser.startup.blankWindow is set to 'false' as default.
The latest Fx62.0a1 has the config pref set to 'true' by default.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.