Fire browser-idle-startup-tasks-finished after idle startup tasks have finished

RESOLVED DUPLICATE of bug 1496684

Status

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1496684
Last year
4 months ago

People

(Reporter: mconley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

browser-idle-startup-tasks-finished is an observer notification that was added in bug 1458375 that acts as the "endpoint" for the ScriptPreloader[1]. It used to wait for browser-delayed-startup-finished, but we figure that widening the window makes good sense.

We should make sure that GeckoView (and things using it, I guess?) fires this notification to "close the window" once their start-up idle tasks are done to make sure those scripts get properly pre-parsed and cached.

[1]: If you're not familiar with ScriptPreloader, I wrote about it here: https://mikeconley.ca/blog/2018/05/30/firefox-performance-update-9/
Jim says this bug can be a P3. This feature should help startup performance with cached scripts.
Priority: -- → P3

Updated

6 months ago
Product: Firefox for Android → GeckoView

Required notifications added to GeckoView as part of bug 1496684.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1496684
You need to log in before you can comment on or make changes to this bug.