Autocomplete in location bar should have a sorting option to sort by frequency of access

VERIFIED DUPLICATE of bug 78270

Status

--
enhancement
VERIFIED DUPLICATE of bug 78270
17 years ago
14 years ago

People

(Reporter: bugzilla2, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020519
BuildID:    2002051908

Best described by an example
Lets say I go to a site quite often. One time I had to enter a long URL to get
directly to a certain page eg
http://test2.mel.solnet.com.au/amconsole/base/AMAdminFrame
Then lets assume that most of the time I just want to access the main page so I
start typing test2 and all the matches come up but
http://test2.mel.solnet.com.au is 5 or 6 entries down from the top and
http://test2.mel.solnet.com.au/amconsole/base/AMAdminFrame and longer ones are
at the top.

It would be good to be able to control/provide some options on the sort order of
the history. I think the option already there "match only typed urls" is a good
start, but this is too limiting as I often want to go straight to pages that I
have got to via a link and have never typed eg I may want to go to
http://test2.mel.solnet.com.au/amconsole/policy/PMOrgNav?PMOrgNav.OrgTiledView[0].hrefOrg=o=solnet.com.au,o=isp&jato.pageSession=AKztAAVzcgARamF2YS51dGlsLkhhc2hNYXAFB9rBwxZg0QMAAkYACmxvYWRGYWN0b3JJAAl0aHJlc2hvbGR4cD9AAAAAAAAIdwgAAAALAAAABXQAKWNvbS1pcGxhbmV0LWFtLWFkbWluLXVzZXItY3VycmVudC1zdWJ2aWV3dAABMXQAImlwbGFuZXQtYW0tYWRtaW4tY29uc29sZS12aWV3LW1lbnV0AAZwb2xpY3l0ABJhbVNlbGVjdGVkU2VydmljZXN0ABhpUGxhbmV0UFNEZXNrdG9wU2VydmljZTx0ABZhbS5jdXJyZW50LnBvbGljeS5tZW51dAABMnQAImNvbS5pcGxhbmV0LmFtLmNvbnNvbGUubG9jYXRpb24tZG50AAVvPWlzcHg$
but I have never typed this but it should appear as one of the urls in the
location bar.
Also, as I wish to primarily access only the main page, perhaps an option to
sort by URL length or even better, frequency of access would be preferable.

So I suppose this is a request to provide an option to make the location bar
autocomplete sort matching URLs by frequency of access

Comment 1

17 years ago
this is an RFE - modifying severity.

So the fix for bug 78270 does not cover this?
Severity: normal → enhancement

Comment 2

16 years ago
No response from reporter. So I guess it is covered.

pi

*** This bug has been marked as a duplicate of 78270 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.