Closed Bug 1466166 Opened 2 years ago Closed 2 years ago

gc\bug-1464872.js | Error: Incremental GC already in progress on beta branch

Categories

(Core :: JavaScript: GC, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr60 --- fixed
firefox61 --- fixed
firefox62 --- fixed

People

(Reporter: jonco, Assigned: jonco)

References

Details

Attachments

(1 file)

This is a test code problem with the test code in bug 1464872.  I don't know why this is only showing up on beta.
Doesn't reproduce for me, but it seems to be gcslice() complaining because GC zeal already started a collection.  I don't know how that managed to happen seeing as we just finished gc() though.  Anyway, this should fix it.
Attachment #8982572 - Flags: review?(sphink)
Comment on attachment 8982572 [details] [diff] [review]
bug1466166-fix-testcode

Review of attachment 8982572 [details] [diff] [review]:
-----------------------------------------------------------------

Oh, I see.
Attachment #8982572 - Flags: review?(sphink) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b84e8b8c441d
Fix test code for bug 1464872 to work with GC zeal. r=sfink
https://hg.mozilla.org/mozilla-central/rev/b84e8b8c441d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.