Permafailing browser_inspector_highlighter-cssshape_06.js | This test exceeded the timeout threshold. when Gecko 62 merges to Beta on 14-06-2018

RESOLVED FIXED in Firefox 62

Status

defect
P3
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: nataliaCs, Assigned: rcaliman)

Tracking

({regression})

unspecified
Firefox 62
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62+ fixed)

Details

Attachments

(2 attachments)

[Tracking Requested - why for this release]:
Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=86bd65f4193bb4d637ef137f0a07dd404bc8abbe&group_state=expanded&selectedJob=181367542

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=181367542&repo=try&lineNumber=6191

09:31:53     INFO - Scaling from sw
09:31:53     INFO - Buffered messages logged at 09:31:46
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset sw moved right after sw scale - 
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset sw moved down after sw scale - 
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset width reduced after sw scale - 
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset height reduced after sw scale - 
09:31:53     INFO - Scaling from se
09:31:53     INFO - Buffered messages logged at 09:31:47
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset se moved right after se scale - 
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset se moved down after se scale - 
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset width reduced after se scale - 
09:31:53     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | #inset height reduced after se scale - 
09:31:53     INFO - Turn off shapes highlighter for #inset
09:31:53     INFO - Toggle shapes highlighter off for clip-path on #inset
09:31:53     INFO - Leaving test bound 
09:31:53     INFO - Buffered messages logged at 09:31:53
09:31:53     INFO - Removing tab.
09:31:53     INFO - Waiting for event: 'TabClose' on [object XULElement].
09:31:53     INFO - Got event: 'TabClose' on [object XULElement].
09:31:53     INFO - Tab removed and finished closing
09:31:53     INFO - Buffered messages finished
09:31:53     INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. - 
09:31:53     INFO - GECKO(1976) | MEMORY STAT | vsize 5195MB | residentFast 804MB | heapAllocated 155MB
09:31:53     INFO - TEST-OK | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | took 96576ms

Might be a regression from Bug 1435373
Flags: needinfo?(rcaliman)
Reporter

Updated

a year ago
Summary: Permafailing devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. when → Permafailing browser_inspector_highlighter-cssshape_06.js | This test exceeded the timeout threshold. when Gecko 62 merges to Beta on 14-06-2018
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Updated

a year ago
Product: Firefox → DevTools
Gabriel, or pbrosset, can you help find an owner to fix this test or the underlying cause? We should be starting the beta 1 build today after the merge. While I'm not considering this as a blocker for 62 beta, I'd like it to be a priority so that we can rely on automated test coverage.
Flags: needinfo?(pbrosset)
Flags: needinfo?(gl)

Updated

11 months ago
Flags: needinfo?(gl)
Assignee

Comment 5

11 months ago
I'll look into splitting this test. It loops though a lot checks for translating shapes in all directions.
Assignee: nobody → rcaliman
Status: NEW → ASSIGNED
Flags: needinfo?(rcaliman)
Flags: needinfo?(pbrosset)

Updated

11 months ago
Priority: -- → P3
Comment hidden (mozreview-request)

Comment 7

11 months ago
mozreview-review
Comment on attachment 8986708 [details]
Bug 1466225 - (Part 1) Rename browser_inspector_highlighter-cssshape_06.js

https://reviewboard.mozilla.org/r/251998/#review258456

This looks like moved code only, so I'm fine to R+ this quickly, but before doing so, I'd like to ask that you use the right commands to create those files so that the history is preserved.
Right now, those are 2 entirely new files and looking at the mercurial history won't get you very far and you'd have to understand that that old test file really is what you are looking for.
Instead, you can probably do this:
- copy 06.js into 06-scale.js
- remove whatever you need to remove from that new 06-scale.js file
- rename 06.js to 06-translate.js
- remove whatever you need to remove from 06-translate.js.

I think you can do these operations with either hg or git in a way that history will be preserved: from any of these 2 files you'll be able to just go up the chain of parents to see previous changes.
Attachment #8986708 - Flags: review?(pbrosset)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 11

11 months ago
mozreview-review
Comment on attachment 8986708 [details]
Bug 1466225 - (Part 1) Rename browser_inspector_highlighter-cssshape_06.js

https://reviewboard.mozilla.org/r/251998/#review258514
Attachment #8986708 - Flags: review?(pbrosset) → review+

Comment 12

11 months ago
mozreview-review
Comment on attachment 8986773 [details]
Bug 1466225 - (Part 2) Split scale and transform shape path editor test to prevent exceeding max test run time.

https://reviewboard.mozilla.org/r/252066/#review258516
Attachment #8986773 - Flags: review?(pbrosset) → review+

Comment 14

11 months ago
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf183f5fce6a
(Part 1) Rename browser_inspector_highlighter-cssshape_06.js r=pbro
https://hg.mozilla.org/integration/autoland/rev/1f05dd7f51b5
(Part 2) Split scale and transform shape path editor test to prevent exceeding max test run time. r=pbro

Comment 15

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cf183f5fce6a
https://hg.mozilla.org/mozilla-central/rev/1f05dd7f51b5
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
You need to log in before you can comment on or make changes to this bug.