Closed Bug 1466596 Opened 6 years ago Closed 1 year ago

Crash in mozilla::ContentCacheInParent::OnEventNeedingAckHandled

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox-esr102 --- wontfix
firefox-esr115 --- wontfix
firefox62 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox98 --- wontfix
firefox99 --- wontfix
firefox114 --- wontfix
firefox115 --- wontfix
firefox116 --- fixed

People

(Reporter: MatsPalmgren_bugz, Assigned: masayuki)

References

Details

(Keywords: crash, inputmethod, topcrash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-e6f5a03a-1297-4382-86bc-920970180604.
=============================================================

MOZ_CRASH Reason:  MOZ_RELEASE_ASSERT(false) (No pending composition but received unexpected commit event)


Top 10 frames of crashing thread:

0 xul.dll mozilla::ContentCacheInParent::OnEventNeedingAckHandled widget/ContentCache.cpp:1250
1 xul.dll mozilla::dom::TabParent::RecvOnEventNeedingAckHandled dom/ipc/TabParent.cpp:1976
2 xul.dll mozilla::dom::PBrowserParent::OnMessageReceived ipc/ipdl/PBrowserParent.cpp:2596
3 xul.dll mozilla::dom::PContentParent::OnMessageReceived ipc/ipdl/PContentParent.cpp:3501
4 xul.dll mozilla::ipc::MessageChannel::DispatchAsyncMessage ipc/glue/MessageChannel.cpp:2134
5 xul.dll mozilla::ipc::MessageChannel::DispatchMessageW ipc/glue/MessageChannel.cpp:2064
6 xul.dll mozilla::ipc::MessageChannel::RunMessage ipc/glue/MessageChannel.cpp:1910
7 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1943
8 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1088
9 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:97

=============================================================
Priority: -- → P5

Updating flags since this crash is present on 68/67/66. Also changing platform since it happens on Mac as well.

OS: Windows 10 → All
Hardware: Unspecified → All

Marking this as Resolved > Worksforme since there are no more crashes with this signature in the past 6 months.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME

Unfortunately, nowadays, the signature is still there, so I reopen this bug.

Severity: critical → S3
Priority: P5 → P3
See Also: → 1405832

I guess that it's resurrected by Fission work or something touching IPC timings. Another reason crash is reported as bug 1690827.

Component: DOM: Content Processes → DOM: UI Events & Focus Handling
Keywords: inputmethod
See Also: → 1690827

Crash rate (= diagnostic asserts) for this changed from 1-2 crashes per beta for Firefox 114 to ~10-15 for Firefox 115.

Masayuki, could you check why the volume increased and if anything needs to be done?

Flags: needinfo?(masayuki)

(In reply to Sebastian Hengst [:aryx] (needinfo me if it's about an intermittent or backout) from comment #5)

Crash rate (= diagnostic asserts) for this changed from 1-2 crashes per beta for Firefox 114 to ~10-15 for Firefox 115.

Masayuki, could you check why the volume increased and if anything needs to be done?

It's caused by a regression of the fix of bug 1690827. Now, the follow up patch is landed. So, the crash rate should be go down to 0.

Flags: needinfo?(masayuki)

The bug is linked to a topcrash signature, which matches the following criterion:

  • Top 10 desktop browser crashes on nightly

:edgar, could you consider increasing the severity of this top-crash bug?

For more information, please visit BugBot documentation.

Flags: needinfo?(echen)
Keywords: topcrash

It seems that this is now completely fixed in bug 1690827.

Assignee: nobody → masayuki
Status: REOPENED → RESOLVED
Closed: 3 years ago1 year ago
Resolution: --- → FIXED
Depends on: 1690827
See Also: 1690827
Target Milestone: --- → 116 Branch
You need to log in before you can comment on or make changes to this bug.